Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-19-2009, 09:39 AM   #1
LQ Newbie
Registered: Dec 2008
Location: UK Lancashire
Distribution: Ubuntu 8.10
Posts: 27

Rep: Reputation: 15
Ubuntu 9.04 wireless connection failed.

I have a problem connecting wirelessly to the internet with my laptop on ubuntu 9.04,my PC on windows XP is working OK wireless on Sky broadband.Now if I disable the security on my router on the setup page the laptop will connect wirelessly,but no way will it connect if any security is on the router.The router security is set up on WAP-PSK(WI FI PROTECTED ACCESS PRE -SHARED KEY.So my question is how do i set this password up on the Linux m/c,which option do I use.I have tried variuos ways but I canot get it to connect.

The options on the router are,

Security Options
WEP (Wired Equivalent Privacy)
WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

The options on the linux laptop are,

Thank you.
Old 09-21-2009, 03:10 PM   #2
Registered: Jan 2006
Distribution: Fedora, Ubuntu, Slackware
Posts: 56

Rep: Reputation: 15
Best way would be to set the router to WPA-PSK and the linux laptop (Ubuntu 9.04) to WPA/WPA2 - Personal
Old 09-21-2009, 09:21 PM   #3
LQ Newbie
Registered: Sep 2007
Posts: 7

Rep: Reputation: 0
On the router side you need to enable WPA-PSK. You also need to define a proper SSID for the network.

On the laptop you need to mention the SSID in the security setting select "WPA & WPA2 Personal".
Old 09-21-2009, 09:51 PM   #4
LQ Newbie
Registered: Sep 2009
Distribution: kubuntu 9.04
Posts: 4

Rep: Reputation: 0
if your problem is not solved yet:

you'r at home, so if u have acess to the router, u can change your protection for mac adress filter.

checking for macs in this case only the wireless card one.
linux system: terminal: ifconfig -a or sudo ifconfig -a
windows system: run -> cmd -> ipconfig/all
Old 10-01-2009, 06:42 PM   #5
LQ Newbie
Registered: Oct 2009
Posts: 2

Rep: Reputation: 0
same problem

i am having the same problem where i can connect on xp but not ubuntu 9.04 on a netgear with the 'WPA-PSK(Wi-Fi Protected Access Pre-Shared Key)' selected on the router.

any ideas on this?
Old 10-02-2009, 09:28 AM   #6
LQ Newbie
Registered: Oct 2009
Posts: 2

Rep: Reputation: 0
now this works

after letting my computer hibernate overnight, connecting to a WPA-PSK network works using the same password. i didn't have to re-enter, the password that was failing the previous evening worked.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless connection through Ubuntu. eaivision Linux - Newbie 2 06-30-2009 03:43 PM
Ubuntu newb: How do I get my wireless connection working with Ubuntu? devilgates Linux - Newbie 12 02-21-2008 08:05 PM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover SUSE / openSUSE 8 02-22-2005 08:57 AM
Wireless connection using MA410 failed M3CH4NiX Linux - Wireless Networking 1 03-11-2004 05:15 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:26 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration