LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2008, 04:53 PM   #1
Cubytus
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 8.04 (niooB inside ;)
Posts: 4

Rep: Reputation: 0
Ubuntu 8.04 with ATI Xpress 200: vesa or fglrx=bad resolution


Hi to all,

this topic is to require some help as I've tried pretty much I knew about tweaking xorg to get it to work. I have installed Ubuntu on a HP DC5750 computer which sports an integrated ATI Radeon Xpress 200 video card.

My goal is to make it work by giving a proper resolution/refresh rate/depth to the ViewSonic E771 CRT that's plugged in. IF I can have 3D rendering support it will be a plus, but it's not mandatory in any way. This computer is not mine, so I can't modify it any way I want; plus, I don't want to invest in any way neither in a "public" computer. Linux is ther because Windos doesn't know how to deal properly with 3GB RAM.

Currently, it seems that the computer either starts with xorg.conf.failsafe or xorg.conf. The resolution at this time is an ugly 800x600@60Hz@16bits. If I modify the "Virtual" size of the xorg.conf.failsafe then restart the X server without rebooting, it goes up to 1280x1024, still at 60Hz+16bits. The other resolution provided is an impossible 1024x768@85Hz. I just want it to use 1152x864@75Hz@24 bits, as it did under Win XP.

I tried: to install the proprietary fglrx drivers through the restricted drivers updater in Ubuntu; de-installed them, rebooted, tried with EnvyNG; same result. It still starts with vesa driver and ati driver (I don't know where the two driver come from, maybe on for each of the display ports). However, the restricted drivers manager indicates that fglrx is loaded and activated (which obviously it's not, seing the miserable, fairly constant 500fps I get in glxgears.)

I also tried to force a bigger virtual screen size in xorg.conf, trying to fool the vesa driver it has a bigger screen plugged in; no result. No result either when I just tried to rebuild the xorg.conf from scratch using .failsafe as a template, adding each line by hand.

Now I've run out of niooB's way of doing things.

Well, I know that the Xpress 200 is very tricky to get to work in Linux, but so far the solutions that some people applied to solve the problem were either too old to be applied here, or didn't worked for me.

Any help is welcome, this 60Hz rate is burning my eyes
 
Old 09-23-2008, 10:21 PM   #2
amishtechie
Member
 
Registered: Apr 2004
Location: Oberlin, OH
Distribution: Slackware
Posts: 119

Rep: Reputation: 16
Have you tried this? Hope it helps.
 
Old 09-24-2008, 01:17 AM   #3
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
You could post your xorg.conf here so we at least know what you have got.
 
Old 09-24-2008, 08:52 AM   #4
Cubytus
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 8.04 (niooB inside ;)
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks amishtechie for pointing this one, I did remember having done all the steps described, except removing mesa indirect rendering files. Nevertheless I did installed from ATI's downloaded Catalyst once again, then followed the configuration.

The difference between my first attempts and the somewhat successful one:
1- I've now done sudo aticonfig --initial -f, adding the -f flag;
2- I've shut off the monitor during the boot so as it couldn't be detected and that X instead uses correct parameters instead of falsely detected ones

The Xorg.conf that works: (I deleted some empty lines to make it clearer for low-resolution screens)
Code:
# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
	Load  "glx"
	Load  "GLcore"
	Load  "v4l"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "ca"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
And the xorg.conf that wouldn't allow me to change resolutions and won't use fglrx drivers:
Code:
# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier	"Default Layout"
  screen 0 "Screen0"	0 0
EndSection

Section "Files"
EndSection

Section "Module"
	Load		"glx"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"ca"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
EndSection

Section "Monitor"
	Identifier	"Monitor0"
	VendorName	"ViewSonic"
	ModelName	"E771"
	HorizSync	30-70
	VertRefresh	50-120
EndSection

Section "Device"
	Identifier	"Card0"
	Driver		"fglrx"
	Option		"VideoOverlay"	"on"
	Option		"OpenGLOverlay"	"off"
#	Busid		"PCI:1:5:0"
EndSection

Section "Device"
        Identifier      "Card0"
        Driver          "fglrx"
        Option          "VideoOverlay"  "on"
        Option          "OpenGLOverlay" "off"
       Busid           "PCI:1:5:1"
EndSection

Section "Screen"
	Identifier	"Screen0"
	Device		"Card0"
	Monitor		"Monitor0"
	Defaultdepth	24
	SubSection "Display"
		Depth	24
		Modes		"1152x864"	"1024x768"
		Virtual	1152 864
	EndSubSection
EndSection

Section "Extensions"
	Option		"Composite"	"disable"
EndSection
As it is now, the problem is only half solved; whenever I attempt to put manual settings for the monitor, these are overriden, and I need to shut it off during the boot and rely on the sounds to know when to turn it back on. This isn't a reliable solution in my opinion, as I haven't understood what was going on with X overriding monitor's settings.

If you want I will post wether ATI's configuration panel works or not to correct the situation.
 
Old 09-24-2008, 11:59 AM   #5
amishtechie
Member
 
Registered: Apr 2004
Location: Oberlin, OH
Distribution: Slackware
Posts: 119

Rep: Reputation: 16
May I ask how you are trying to set the resolution for your monitor in your xorg file?

I have manually set mine and did it like this.

Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    16
    SubSection     "Display"
        Depth       16
	Modes      "1440x900"
    EndSubSection
EndSection
The only thing you would want to do is add the modes line and enter the resolution you prefer.
You would probably also want to add this section as well.

Code:
Section "DRI"
    Mode 0666
 EndSection
And under your modules section you will want to add this line.

Code:
Load  "dri"
This will enable direct rendering.
 
Old 10-31-2008, 11:20 PM   #6
Cubytus
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 8.04 (niooB inside ;)
Posts: 4

Original Poster
Rep: Reputation: 0
Hi,

a little update there: after a week it has worked flawlessly (although I didn't dared rebooting), the problem is back again.

First time, I booted into recovery mode, dropped to a root shell prompt, entered aticonfig --initial -f, rebooted and it worked.

Now, the best I can have is fglrx enabled, but when I log in, the desktop and bars are respectively light grey, and white. I know the computer is working, because if I place my mouse cursor (which I can see, strangely) at the top leftmost corner, I can click and a white shadow appears over the grey area, which is surely the Application menu. Ironic is that even the Desktop Cube is enabled! I can turn it any way I want, it's white everywhere.

This is on the same computer, but, frankly, I'm starting to understand why the computer'S owner, a scientist, wants to trash Linux out ouf the window, if only his lab had one, and reformat to Windows. There, I don't have any statement to show him that Ubuntu is more powerful than Win.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon Xpress 200 izelpii Linux - Hardware 44 10-30-2007 10:00 AM
ATI Xpress 200 chipset problems? I need help. ogwilson Linux - Hardware 2 08-25-2007 10:00 AM
ATI xpress 200 - is hardware acceleration actually working? jacksmash Linux - Hardware 3 03-04-2007 08:32 AM
Help with ATI Radeon Xpress 200 The Dew Linux - Hardware 6 02-11-2007 12:58 AM
ati xpress 200... resolution..FC6 praveen_2003 Fedora 1 12-19-2006 09:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration