-   Linux - Newbie (
-   -   Ubuntu 8.0.4 dell wireless verizon dsl MODEM westll veralink model 327w (

psjean 05-24-2008 01:31 AM

Ubuntu 8.0.4 dell wireless verizon dsl MODEM westll veralink model 327w
I am new to Linux so please forgive my dumb questions.
I just download Ubantu 8.0.4 to my laptop which is a Dell laptop, Inspiron 5150.When I run Verizon Wirless under Microsoft Window, everything works OK. Also, when I run Ubuntu and uae direct conntect to the Ethernet port of the DSL Modem, everything is fine too. The only problem is when I run Ubuntu with Wireless. I try to configure Linux wireless through Ubuntu network admin menus fails. No batter what I do DHCP ordeidicated IP address, I cannot let the system keep the wirelss available. It will show wireless as an empty box instead of a tick (I assume means selected). However, if not selcted, it will show as "-" in the slected box. I am confused; I guess I am not familair with Ubantu and linux netowrk admin. Below is my laptop and dsl information:

DSL: Verizon Westell Versalink Model 327W
Laptop: Dell Inspiron 5159
Network Card: (I copy this info. from Microsoft Window side)
Dual Truemobile 1300 WLAN mini PCI Card Rev. 4.5
Chipset BCM4306/BCM2050
Mac A ddress 00904B62F7AB
Driver Version
Built by WINDKK Drive Date 2.10.2005

AP's Address
Mac Address 00:E0:98:05:BB:26

If any of you can help; I will be very appreciated.

PTrenholme 05-24-2008 07:38 PM

Generally, you need to install the "firmware" in order to use the B43 driver for Broadcom chipsets. (Which is what you have - a BCM 4306, just like the one in my laptop.) I don't have Ubuntu installed on my laptop, so I can't speak with any authority about Broadcom wireless setup for Ubuntu, but - IIRC - the Ubuntu LiveCD did work when I tried it on my laptop.

If that's true, it should have worked "out of the box" for you, so I guess wy recollection is not correct, eh?

Check to see if you have a program "b43-fwcutter" installed on your system. (I.e., start a terminal window and run the command whereis fw-cutter) If you do, run it and point it to the CD with the Broadcom wireless drivers on it. (That's the CD that came with your laptop. You may need to find the "wireless driver subdirectory" on it to locate the *.sys file you'll need, which will probably be called something like truemob.sys, but that's just a guess.) Use the command sudo fw-cutter to run it, and write the output to /lib/firmware. (You need "root" access to write to /lib - that's what the sudo prefix does for you.)

Before doing all that, you might want to check the "restricted" repositories to see if there might be a Brodcom 4306 driver there you could load.

Oh, another question: what security are you using on your wireless connection? If it's WPA or WPA2 you may also need to install the wpa_supplicant package.

psjean 05-29-2008 12:16 AM

Try and Fail
I have my officemate who is very familiar with LINUX. He thinks the driver is in (with the UBUNTU CD). Since my office does not have wireless, we cannot find out what is wrong. I try to bring the wireless up but fail. I went into my DSL modem configuration but the set up menus are different from MsWindow's. Well, I think I need to talk to UBUNTU and tell them my MsWindow Wirless setup. Any of you have better idea? Also, I think I will take my laptop to local library which has WIFI thre so I can try with non-secure wireless there to see what is wrong, any comment?

Thanks for all of your help


All times are GMT -5. The time now is 06:17 AM.