LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ubuntu 7.04 fails to start normally (https://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-7-04-fails-to-start-normally-597210/)

peteh 11-05-2007 03:46 AM

Ubuntu 7.04 fails to start normally
 
I got a new Dell Inspiron 530S. It had Windows Vista pre-installed (in NZ we can't order a Dell with Ubuntu). I tried installing the standard distro but found some hardware issues. Eventually I found the Dell Remastered Ubuntu 7.04 ISO and installed it.

This resolved all noticeable hardware problems. However, I wanted the kde desktop so I did:

Code:

sudo apt-get install kubuntu-desktop
All worked fine for a while but now, when I start the machine normally I get to the kubuntu logo screen immediately after the GRUB boot loader disappears and then it stalls for a very long time until I get a bunch of messages as follows:

Code:

BusyBox v1.1.3 (Debian 1:1.1.3-3ubuntu3) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off
(initramfs) [ 204.371343] ata2.00: failed to set xfermode (err_mask=0x40)
[ 235.301157] ata3.00: failed to set xfermode (err_mask=0x4)
[ 270.720996] ata3.00: failed to set xfermode (err_mask=0x4)
[ 306.140855] ata3.00: failed to set xfermode (err_mask=0x4)

If I reboot and go into the GRUB menu and select:

Ubuntu, kernel 2.6.20-16-generic (recovery mode) the machine starts ok and I can type kdm at the first prompt to get to the normal logon screen.

What is going on and is there a way to fix this?

Pete

jay73 11-05-2007 09:22 PM

I ran into the same issue with Ubuntu 6.10 and Debian Etch and I seem to remember that it is caused by an inadequate initial ramdisk. Apparently, it can be solved by having the ramdisk recreated but I never bothered doing so as I moved on to Feisty shortly afterwards. There was some discussion of the issue on the Ubuntu forums back then so as long as you know how to google, I'm sure you'll find the workaround.


All times are GMT -5. The time now is 04:22 PM.