-   Linux - Newbie (
-   -   Ubuntu 10.10 to Win7 Pro using either TSClient or Remmina - mapped drive issues. (

Shike 10-17-2010 04:16 AM

Ubuntu 10.10 to Win7 Pro using either TSClient or Remmina - mapped drive issues.

I posted this on the Ubuntu forums a short while back, but it seems I may have stumped those that actually saw it (it gets buried fast there). Anyway, this is the problem I'm having.

I'm wanting to remote into my Win7 machine at home to copy a file to my Ubuntu laptop. I've disabled my firewall. Worth noting is I have changed my default remote port to 22, though it shouldn't cause an issue AFAIK. I have selected to share one of my folders in my home directory. I select to map the folder or entire drive and connect. I get to the Ubuntu folder which I wish to copy items into, and in doing so I get this error:

"\\tsclient\shike\Documents is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Attempt to access invalid address."

Mapping a drive through Windows to Windows remote session has had no such issues. I also tried copying from the mapped drive and get the same issue. After the error occurs the drive is completely inaccessible till I reconnect.

Does anyone know how to get around this, or can suggest an alternative way of accessing my files remotely that will work? Thanks.

Shike 10-17-2010 04:00 PM

More info:

I only get the error when actually trying to read or write files specifically to the drive. For example I can see the files in the drive just fine, proper names and all. However, when I highlight them or try to get properties that's when the error occurs. The error also occurs when I attempt to write files to the drive.

myownlittlworld 03-06-2014 10:49 PM

Shared Drive Permissions
Fix the permissions on the shared folder to fix this issue.

Non-private Folders should have permissions: 755 (owner can modify, everyone else can read, can set directory as pwd)
Non-private Files should have permissions: 644 (owner can modify, everyone else can read)

I ran into this issue earlier today and checked the permissions on the folder I was trying to share and they were too restrictive (400 for both files and folders), and by modifying the permissions (right-clicking the folder and going into the Properties), I was able to then use the shared folder in Remmina.

All times are GMT -5. The time now is 10:12 AM.