-   Linux - Newbie (
-   -   Ubuntu 10.10 boots to Grub bash only (

crashhh 05-19-2011 09:12 AM

Ubuntu 10.10 boots to Grub bash only
Hi. I had Ubuntu installed via wubi and been using it for some time now. Never had problems until today.

The screen where it displays Windows XP and Ubuntu gets shown, I choose Ubuntu. Then the second screen with which you can choose Generic, Generic (Recovery Mode), etc (Sorry I'm a newbie and I don't know what it's called) doesn't show. It goes to the grub command line and honestly, I don't know how to get past that.

Please help, thank you.

yancek 05-19-2011 09:20 AM

Did you make any changes or do any updates just prior to this occurring?
Check this site, Section 10, Command Line and Rescue Mode: Line and Rescue Mode

Were you using the xp bootloader to boot both systems?

crashhh 05-19-2011 09:24 AM

I did not see any updates as I run the update-manager on startup. It was working the night before.
And I think I've always used grub when booting up whether windows or ubuntu. Thanks, I'll look into that manual.

crashhh 05-21-2011 06:45 AM

Hi. So Tried the steps in the section "Using CLI to Boot" from the link given, also the steps in this page:

Here's my setup. Windows XP is on C: partition, and Wubi is in D:\Ubuntu. When I set root to loop0, and type "linux /boot/vmlinuz- and press TAB, it doesn't show any kernels available. When I hit enter, it says something like "the disk isn't available".

When I set root to (hd0,1) (C partition), it doesn't find any kernels, but there's this folder: (hd0,1)/boot/ and the fles are BCEDIT and something else.

When I set root to (hd0,1) (D partition), no kernels, no boot folder whatsoever.

I'm really stuck and I don't know what to do next. I don't have much files on my Wubi installation, but what I'm actually trying to save is the programs I've installed and the settings I've had. Thanks people.

syg00 05-21-2011 06:57 AM

I would suggest you read this instead.
(note: I've never used wubi).

crashhh 05-21-2011 08:22 AM

Oh wow. I know why the steps wouldn't work. I just found out that /disks/root.disk is gone from my wubi installation. Wow. And I don't know how that happened. I hope system restore would fix this :( Thanks anyway guys.

All times are GMT -5. The time now is 01:30 AM.