-   Linux - Newbie (
-   -   Ubuntu 10.04 wireless problems Dell latitude d610 Dell mini wlan 1470 (

Westz 10-31-2010 04:48 PM

Ubuntu 10.04 wireless problems Dell latitude d610 Dell mini wlan 1470
similar to this problem i cannot seem to get the wireless card to turn on. ive tried NTDISGTK and Ntdiswrapper to no avail. it recognizes that the hardware is there, but will not turn it on. in terminal i have tried to force start it, but from what i remember, it gives me an error about authentication (might be access not authentication) ill get back here when i boot ubuntu and take some screenshots, at the moment i's running XP and hating it.

markush 10-31-2010 05:04 PM

Hello Westz and welcome to LQ,

I did not understand from your post if your Wlandevice is working or not. If you have a problem to authenticate at the accesspoint, I'd guess that your wlandevice is working. Please post the output of the following commands:

/usr/sbin/lspci | grep -i net



Westz 10-31-2010 06:19 PM

1 Attachment(s)
heres iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

pan0 no wireless extensions.

then theres this...

bash: /usr/sbin/lspci: No such file or directory

i dont see why youd need ifconfig but whatever

l1nuxn00b@UbuntuCoreD610:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:14:22:c3:b2:7a
inet addr: Bcast: Mask:
inet6 addr: fe80::214:22ff:fec3:b27a/64 Scope:Link
RX packets:69201 errors:0 dropped:0 overruns:0 frame:0
TX packets:52918 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:84084139 (84.0 MB) TX bytes:7306514 (7.3 MB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

heres a screenshot that might say a bit
Attachment 5047


found this with the dmesg command in terminal
[ 27.708423] b43 ssb0:0: firmware: requesting b43/ucode5.fw
[ 27.717352] b43 ssb0:0: firmware: requesting b43-open/ucode5.fw
[ 27.726402] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 27.726481] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
[ 27.726558] b43-phy0 ERROR: You must go to and download the correct firmware for this driver version. Please carefully read all instructions on this website.

markush 10-31-2010 07:14 PM

Well, iwconfig tells us, that the wireless-device isn't connected to the accesspoint and ifconfig tells us that it is even not started. What happens when you try to start the wlan? I'm not experienced with Ubuntu, so I don't know how to start the wlan in that distro. In your first post you wrote that you get an error about authentification, but this provides that wlan0 is started.


Westz 11-02-2010 02:50 PM

i also dont know how to start it. im pretty sure starting it is where i find problems, ive never gotten to a point where i can see available networks from the default network utility. i used a USB wireless adapter at one point, which worked, and i remember i was trying to crack WEP keys and part of that was turning it off in terminal, but for the life of me i cant remember the command to do it. looks like im going back to youtube for a video just for one command... heh.

almug 02-01-2018 04:11 AM

wifi stopped to work on D610 Mint
Same problem I had with Dell D610 Linux Mint 17.2 XFCE and Broadcom wireless 1470 dual band WLAN (B43 model BCM4318 airforge 54g).
Problem was origianted by an unluky update of the driver with a "recommended" notice (bad recommendation!!!) with a kernel original one. Switch back to the old firmware B43 legacy driver was not then allowed.
Solution: after a number of tentative operations the solution was to unistall all NDISWRAPPER packages, go to driver manage and reinstall firmware-B43legacy driver. After a couple of reboots the led of wifi turned on and connection to the net is now working.

GREAT! Many thanks to Quakeboy02 and markush

All times are GMT -5. The time now is 10:19 AM.