LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2005, 12:03 PM   #1
blueprobe
LQ Newbie
 
Registered: Feb 2005
Distribution: slackware 10.1
Posts: 9

Rep: Reputation: 0
Turn off pcspeaker


Hi, im a real noob with linux

ok here come my first question in linuxquestions

everytime i try to tab a filename or something in aterm, and when it doesn't exist, i hear this annoying sound from my PC speaker. Please, tell me how i turn it off beside pulling out a cable in the computer.

Last edited by blueprobe; 02-22-2005 at 12:08 PM.
 
Old 02-22-2005, 12:25 PM   #2
jollyjoice
Member
 
Registered: Aug 2003
Location: UK
Distribution: Gentoo 64
Posts: 383

Rep: Reputation: 30
got a gui? I think the mixer has a PC-Speaker channel, well i have one.
If not gui then aumix works in console, i think...
 
Old 02-22-2005, 12:30 PM   #3
blueprobe
LQ Newbie
 
Registered: Feb 2005
Distribution: slackware 10.1
Posts: 9

Original Poster
Rep: Reputation: 0
I tried to mute all with aumix but that did not do it. About gui I use fluxbox in slackware and I usually use rexima in the console as my mixer.
 
Old 02-22-2005, 12:42 PM   #4
jollyjoice
Member
 
Registered: Aug 2003
Location: UK
Distribution: Gentoo 64
Posts: 383

Rep: Reputation: 30
well thats me stumped then! You could unplug it or just don't do things to make it beep, yep not very useful i know.
Any1 else got any ideas?
 
Old 02-22-2005, 12:57 PM   #5
Ephracis
Senior Member
 
Registered: Sep 2004
Location: Sweden
Distribution: Ubuntu, Debian
Posts: 1,109

Rep: Reputation: 49
Well, I had to help him to remove the cable from the motherboard but if anyone could tell me how to disable the speaker without touching the hardware I would be grateful. I really hate it when pc-speakers get on my nervs. :P
 
Old 02-22-2005, 12:58 PM   #6
blueprobe
LQ Newbie
 
Registered: Feb 2005
Distribution: slackware 10.1
Posts: 9

Original Poster
Rep: Reputation: 0
well, i unplugged the pc speaker cable, so the problem is kind of solved but the light that indicates that the computer is working is now off by some strange reason, but whata heck, i can live with that
 
Old 02-22-2005, 01:00 PM   #7
blueprobe
LQ Newbie
 
Registered: Feb 2005
Distribution: slackware 10.1
Posts: 9

Original Poster
Rep: Reputation: 0
hehe mezzymeat, my linux-guru
 
Old 02-22-2005, 01:11 PM   #8
titus_a_duxass
LQ Newbie
 
Registered: Feb 2005
Distribution: SuSE 9.1 pro
Posts: 4

Rep: Reputation: 0
Try editing /etc/inputrc and adding the line:
set bell-style none

then log out and log back in.
Worked for me.
 
Old 02-22-2005, 09:01 PM   #9
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
Quote:
Originally posted by titus_a_duxass
Try editing /etc/inputrc and adding the line:
set bell-style none

then log out and log back in.
Worked for me.
The line should already be there, but set to "audible." Simply change audible to none, and the beep will be gone.

--Ian
 
Old 02-22-2005, 09:39 PM   #10
archdev
Member
 
Registered: May 2004
Location: chicago and cincinnati
Distribution: fedora
Posts: 134

Rep: Reputation: 15
Isnt there usually a bios setting for this?
 
Old 02-23-2005, 03:02 AM   #11
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
Quote:
Originally posted by archdev
Isnt there usually a bios setting for this?
But why mess with the bios, when there is a software setting that enables it to be disabled.
This way, if it is necessary for the computer to beep during startup it still can.

--Ian
 
Old 02-23-2005, 03:44 AM   #12
archdev
Member
 
Registered: May 2004
Location: chicago and cincinnati
Distribution: fedora
Posts: 134

Rep: Reputation: 15
Quote:
Originally posted by IBall
But why mess with the bios, when there is a software setting that enables it to be disabled.
This way, if it is necessary for the computer to beep during startup it still can.

--Ian
Fair enough
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 10:39 AM
turn off doesn't really turn and power off pcandpc Mandriva 11 05-30-2005 04:22 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 09:05 AM
?? What Is It ?? How Do I Turn It On ?? Raggit Linux - Newbie 11 03-08-2004 06:30 AM
Turn off ?! kosmognov Linux - Software 3 08-14-2003 12:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration