LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2017, 12:25 PM   #1
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Rep: Reputation: Disabled
Trying To Use Samba First Time Error Message "[Folder name] not accessible You might not have permission to use this network resource"


Dear Forum,

I am using Samba for the first time trying to create a share folder between my Ubuntu 14.04.3 and my Windows 7 Home Premium

I am following the instructions in this guide here:
http://www.howtogeek.com/176471/how-...ows-and-linux/

Unfortunately, when I click on the finished shortcut in Windows 7 after typing in my user name and password I am given an error message that "[folder name] is not accessible You might not have permission to use this network resource"

smb.conf checks out fine

[Share]
path = /home/joe/Desktop/Share
; available = yes
writeable = yes
; browseable = yes
guest ok = yes

Samba pdbedit shows user is there also

joe:1000:Joe
root:0:root

Any suggestions would be really helpful -- thanks!
 
Old 01-05-2017, 12:34 PM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 9,356
Blog Entries: 13

Rep: Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411
Have you tried adding valid users=joe to that smb.conf?
 
Old 01-05-2017, 12:41 PM   #3
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Hi rtmistler,

I did smbpasswd -a joe and changed my password a couple times

I'm not quite sure where to edit smb.conf directly to add users I'll try and look.

I even turned off specific users and made guest ok still don't know why it isn't working.

Thanks-
 
Old 01-05-2017, 12:44 PM   #4
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Sorry I just saw what you meant.

Yeah, I did "valid users = Joe" previously then I turned off specific users and made guest okay but still not working

thanks-
 
Old 01-05-2017, 12:47 PM   #5
urbanwks
Member
 
Registered: Sep 2003
Distribution: Slackware64-Current, FreeBSD 12.1, Alpine 5.4, Manjaro 19, Alpine on WSL [Win10]
Posts: 194

Rep: Reputation: 213Reputation: 213Reputation: 213
Make sure your samba domain for the Linux machine is the same as the domain your Windows machine is assigned to.

If it isn't, when logging into the samba server from Windows make sure your user name is linuxdomain/joe, where linuxdomain=whatever your smb domain is on the Linux machine. You can set the domain in smb.conf, if I recall correctly.
 
Old 01-05-2017, 12:50 PM   #6
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by urbanwks View Post
Make sure your samba domain for the Linux machine is the same as the domain your Windows machine is assigned to.

If it isn't, when logging into the samba server from Windows make sure your user name is linuxdomain/joe, where linuxdomain=whatever your smb domain is on the Linux machine. You can set the domain in smb.conf, if I recall correctly.
Hi urbanwks,

Can you explain to me where to check that?

Thanks!
 
Old 01-05-2017, 12:55 PM   #7
urbanwks
Member
 
Registered: Sep 2003
Distribution: Slackware64-Current, FreeBSD 12.1, Alpine 5.4, Manjaro 19, Alpine on WSL [Win10]
Posts: 194

Rep: Reputation: 213Reputation: 213Reputation: 213
Perhaps "workgroup" would have been a better term than domain. Anyway, in smb.conf:

Code:
[global]
    workgroup = beginnermind
In the [global] section of smb.conf (add it if you don't have one), add the above. Name the workgroup whatever you like. Be sure to restart samba.

On the windows machine when it asks for your credentials, use the following:

user: beginnermind/joe
pass: [whatever your password is]

You should be able to check the domain/workgroup on Windows in Control Panel->System. If the two match, you shouldn't have to include the "beginnermind/" (or whatever) in the user ID, just the "joe".
 
Old 01-05-2017, 01:04 PM   #8
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Try creating a 'Map Drive' instead from Windows machine. I found it a lot easier to work with.

Now, if nothing happens still, go back to Ubuntu and open a terminal and try this:

Code:
testparm
file /home/joe/Desktop/Share
grep '^\s*workgroup' /etc/samba/smb.conf
 
Old 01-05-2017, 01:14 PM   #9
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by urbanwks View Post
Perhaps "workgroup" would have been a better term than domain. Anyway, in smb.conf:

Code:
[global]
    workgroup = beginnermind
In the [global] section of smb.conf (add it if you don't have one), add the above. Name the workgroup whatever you like. Be sure to restart samba.

On the windows machine when it asks for your credentials, use the following:

user: beginnermind/joe
pass: [whatever your password is]

You should be able to check the domain/workgroup on Windows in Control Panel->System. If the two match, you shouldn't have to include the "beginnermind/" (or whatever) in the user ID, just the "joe".
Hi urbanwks,

I went into smb.conf and made sure that workgroup = WORKGROUP (all caps) which matches both my Windows 7 machine and what it says in Samba.

My Windows machine also has Linux as a dual boot (it's a still a separate comp from the Ubuntu comp I am trying to share files with) I don't know if that is a factor but when I ask to "switch users" I don't really get any options to change user names.

Still getting the same error though--
 
Old 01-05-2017, 01:19 PM   #10
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by c0wb0y View Post
Try creating a 'Map Drive' instead from Windows machine. I found it a lot easier to work with.

Now, if nothing happens still, go back to Ubuntu and open a terminal and try this:

Code:
testparm
file /home/joe/Desktop/Share
grep '^\s*workgroup' /etc/samba/smb.conf
Hi c0wb0y,

Thanks for your help I got the following error message from terminal:

Load smb config files from file
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.
 
Old 01-05-2017, 01:28 PM   #11
urbanwks
Member
 
Registered: Sep 2003
Distribution: Slackware64-Current, FreeBSD 12.1, Alpine 5.4, Manjaro 19, Alpine on WSL [Win10]
Posts: 194

Rep: Reputation: 213Reputation: 213Reputation: 213
Quote:
Originally Posted by beginnermind View Post
Hi urbanwks,

I went into smb.conf and made sure that workgroup = WORKGROUP (all caps) which matches both my Windows 7 machine and what it says in Samba.

My Windows machine also has Linux as a dual boot (it's a still a separate comp from the Ubuntu comp I am trying to share files with) I don't know if that is a factor but when I ask to "switch users" I don't really get any options to change user names.

Still getting the same error though--
I'm not sure if I completely understand, but from my experience you shouldn't have any options to choose a different username on the Win authentication dialog... you should just be able to type "WORKGROUP/joe" in the user name box.

I might not be able to help any further but if you post your entire smb.conf, someone might be able to spot something.
 
Old 01-05-2017, 02:26 PM   #12
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
It seems samba is not running. Can you confirm by issuing this:
Code:
ss -4tln -o state listening '( sport = :445 )'
 
Old 01-05-2017, 02:58 PM   #13
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Hi!

I got:

Recv-Q Send-Q Local Address:Port Peer Address:Port
0 50 *:445 *:*

I'm running into problems copying and pasting the whole smb.conf using clipboard meanwhile

Thanks for your help-
 
Old 01-05-2017, 03:00 PM   #14
beginnermind
LQ Newbie
 
Registered: Jan 2017
Posts: 13

Original Poster
Rep: Reputation: Disabled
Recev-Q
0

Send-Q
50

Local Address:Port
*:445

Peer Address:Port
*:*
 
Old 01-05-2017, 03:41 PM   #15
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Ok, so samba is running then, but testparm is spitting an error message. Did you try restarting samba?
Can you try to create a Map network drive from Windows? Also, check the samba logs at /var/log/samba.

And it would be very helpful if you can post smb.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I don't can login in PuTTy I get that message: "Network error: Connection refused" nikaway Linux - Security 3 09-24-2015 07:57 AM
Samba "mount error(11): Resource temporarily unavailable" RWallett Linux - Server 1 07-01-2010 01:00 PM
The "init_module: Device or resource busy" message in the 2.4.26 kernel. tommyclee Linux - Kernel 3 12-30-2008 07:09 PM
"Network Cable Unplugged" error message in XP after booting Knoppix NanakiXIII Linux - General 31 05-23-2008 06:21 PM
Logwatch error message "lease broken" related to Samba?? icammy Linux - Server 1 04-19-2007 02:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration