LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Trying to start an X session and I can't (https://www.linuxquestions.org/questions/linux-newbie-8/trying-to-start-an-x-session-and-i-cant-83144/)

justin218 08-18-2003 11:56 AM

Trying to start an X session and I can't
 
I'm running Red Hat 9 and am logged in as a user. When I try to start an X session by typing startx I get the following:
xauth: timeout in locking authority file /root/.xauthMS9HiY

Fatal Server Error:
Server is already active for display 0
If this server is no longer running, remore /tmp/.X0-lock and start again

I am trying to run the mythtvsetup application which requires an X session

acid_kewpie 08-18-2003 12:39 PM

well *IS* there an X session running already? it'd be kinda handy if you told us.... if there really isn't, remove the old lockfile. make sure you are not already logged in as someone else inside X. if you are, just "su" to root and un it then, or prefereably, don't use root at all... i'm sure mythtv can run without root permissions

justin218 08-18-2003 01:11 PM

Well, I don't know, I am very new to this. I try to run mythtvsetup and it says it can not connect to an X server, so I guess that there isn't one running. I have tried removing that file but I still get that message. Perhaps I am logged in as someone else as you said, how do I un it? What do I do once I am logged in as root in the console?

darthtux 08-18-2003 09:49 PM

Try control+alt+F7. If you have an X session running it will take you back to it. Also do the command
ps -aux
you can see the usernames that are logged in and the tty such as if their on tty1, tty2, etc. And you can see if GNOME KDE or a window manager is running.

If someone else is logged in you can always kill their processes with
kill process_id


All times are GMT -5. The time now is 11:50 PM.