-   Linux - Newbie (
-   -   Trying to set up wireless WPA connection on Kubuntu using ndiswrapper (

nishnoob 07-31-2008 07:07 PM

Trying to set up wireless WPA connection on Kubuntu using ndiswrapper
I managed to get to the point of installing ndiswrapper after following a bunch of web postings on how to use ndiswrapper and asking another more experienced linux user. I'm new to all this so please assume that I don't know the first thing about linux!

After getting hold of a driver package from the internet, I did the following -

1. sudo ndiswrapper -i odwgu.inf (install the .inf file - came out of the driver)
2. sudo ndiswrapper -l (checked to see if it would list drivers which it did)

3. sudo modprobe ndiswrapper

4. sudo dmesg (system log said that it loaded the ndiswrapper)

5. iwconfig (used this to check the network interfaces. Incidentally, the wireless card being used here is an Ativa USB card. The available network interface was eth1. Here's where I got stuck, because most of the posts show it as wlan0 not eth1. Does this mean the computer doesn't detect the wireless card? I went ahead and followed the rest of the instructions)

6. sudo iwlist eth1 scan (used this to get statistics and ESSID)

7. sudo iwconfig eth1 essid "South Jersey Shore" (is it a problem if I named my ESSID like this?)

8. sudo dhclient eth1

This is where I got a returned message like this -

localhost dhclient No DHCPOFFERS received.
localhost dhclient No working leases in persistent database - sleeping.

Obviously it's not detecting anything...
What can I do???

Thanks in advance for the help!

Tons of Fun 08-01-2008 07:36 AM

Are you sure that you are connected to your access point? In the title, you stated setting up wpa. Do you have wpa_supplicant installed? The error of No DHCP Offers Received usually indicates that you are not connected, or there is no DHCP server available. Post the results of ifconfig, iwconfig, and your interfaces config file (replace any WEP/WPA keys with X's).

pentode 08-01-2008 09:41 AM

Try turning off WPA and any other security on the wireless router temporarily to see if it will connect. Troubleshoot your connection without WPA until you can connect, then work on WPA.

nishnoob 08-04-2008 04:57 PM

WPA was turned off when I tried this. I double checked and I'm getting the same error message. I'm not sure what you mean by being connected to my access point. That is what I've been trying to achieve, correct?

Tons of Fun 08-04-2008 06:50 PM

It doesn't matter that your system is identifying the wireless adapter as eth1, that's actually quite common. The adapter on my Debian Etch machine and my Mint laptop are both detected as eth1. Some distros detect them as wlan1, and the atheros chipset based wireless adapters are usually detected as ath1. As long as it is detected as a wireless adapter, you are ok.

When you ran iwlist eth1 scan, what was the result? Did you see a list of available connection points?

What distribution are you running (i.e. Fedora, Ubuntu, etc.)?

Finally, what is the results of iwconfig?

All times are GMT -5. The time now is 04:26 PM.