Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-22-2012, 05:49 PM   #1
Registered: Apr 2012
Posts: 213

Rep: Reputation: Disabled
Trying to set OS authentication to Database user

Hai to all ;

I want to set permission to new user (foo). Already oracle user primary group is oinstall it having permission for following files
like this

**as oracle user ;**

PHP Code:
find / -name libsqlplus\* -ls 2>/dev/null
854895 1028 
-rw-r----- 1 oracle oinstall 1047293 Jun 22 2005 /u01/app/oracle/product/10.2.0/db_1/lib/
854890 1296 
-rw-r----- 1 oracle oinstall 1319436 Jun 22 2005 /u01/app/oracle/product/10.2.0/db_1/lib/libsqlplus.a
[oracle@localhost ~]$ whoami
[oracle@localhost ~]$ 
  • rw" for oracle and
  • "r" for members of the oinstall group, and
  • no permissions at all for anyone
I am trying to connect as foo user ,here i need to set permission to foo user. I tried to set but facing error ,

PHP Code:
[root@localhost ~]# useradd foo
[root@localhost ~]# passwd foo
Changing password for user foo.
UNIX password:
BAD PASSWORDit's WAY too short
Retype new UNIX password:
passwd: all authentication tokens updated successfully.

root@localhost ~]# chown :oinstall /u01/
[root@localhost ~]# su - foo
su: warning: cannot change directory to /home/foo: Permission denied
-bash: /home/foo/.bash_profile: Permission denied 
Kindly please help me.

Last edited by thiyagusham; 12-22-2012 at 06:05 PM.
Old 12-23-2012, 12:52 AM   #2
Registered: Jul 2006
Location: Maryland, USA
Distribution: Fedora, PCLinuxOS
Posts: 666

Rep: Reputation: 91
The useradd command doesn't create the home directory by default.
Use the -m switch to make it create the home directory.
1 members found this post helpful.
Old 12-23-2012, 07:26 PM   #3
Registered: Apr 2012
Posts: 213

Original Poster
Rep: Reputation: Disabled
Yes , You are right. Could you please elaborate little more ?

resolved. Yeah , Really good link

Last edited by thiyagusham; 12-23-2012 at 07:33 PM.
Old 12-23-2012, 10:16 PM   #4
Registered: Jul 2006
Location: Maryland, USA
Distribution: Fedora, PCLinuxOS
Posts: 666

Rep: Reputation: 91
Well, it looks like you used useradd without the -m switch and then tried to switch to the home directory of the new user. But that failed because the directory wasn't created. So at this point you can either:
  • use userdel to remove the user and then useradd -m to add it again, or
  • create the directory manually.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Active Directory authentication to a Postgres database kaplan71 Linux - Software 0 12-16-2011 01:30 PM
DBI Connect Failed:Access denied for user ''@'localhost' to database <database> error kaplan71 Linux - Software 3 06-05-2009 01:39 PM
Authentication service cannot retrieve authentication info - for new user yosial Linux - Newbie 2 10-29-2008 12:30 AM
Apache authentication with a database?? helptonewbie Linux - Server 3 09-15-2008 07:51 AM
SET UP USER AUTHENTICATION with COOKIES - EASIEST METHOD\SOFTWARE?? JEFFPINCT Linux - Security 2 05-04-2007 07:59 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:00 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration