Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-29-2003, 04:35 PM   #1
Registered: Nov 2003
Location: Boise, Idaho
Distribution: Fedora 9 x86_64 and Gentoo
Posts: 51

Rep: Reputation: 15
Trying to see what blackbox is like... but I can't seem to switch

I'm currently running KDE as my X window system, and I've heard that blackbox is really small, and so I wanted to try it out. The only problem is That I don't know how to change it. I've looked at the config files and I can't seem to find a place in there where I could change it, and the utility that I used to change from gnome to KDE doesn't have an option for blackbox, so I'm in somewhat of a no-win situation. Any help would be appreciated. Thanks.

Old 12-29-2003, 05:15 PM   #2
LQ Guru
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Perhaps you are using the gdm login manager and need to configure it?

Gdm - GNOME version of xdm

I prefer using a console login, using startx to start the GUI. I create a file .xinitrc in my home directory to do that stuff.

If you would like to do that, edit your /etc/inittab and change the default runlevel to "Full multi user mode" and create a file similar to mine:
# Duron box "uilleann" user fancy .xinitrc file
# Start the stuff I want to run when I startx

# The artwiz-fonts sometimes conflict with your locale settings. To get
# them to work you may have to put the following at the beginning of your
# .xinitrc file
# export LC=C
# export LC_ALL=C

# Set the background for fluxbox
# Esetroot ~/backgrounds/linux.png &

# Start gkrellm and put it in the slit
gkrellm -w &

# This will run a screensaver as your background
# /usr/X11R6/lib/xscreensaver/hopalong -root &

# Start the screensaver daemon
xscreensaver &

# Finally, I start my window manager
exec fluxbox
# exec kde
# exec gnome-session
If you prefer to stick to your gui login, try a search of the board on setting up gdm (or xdm or kdm, whatever you use) to switch to another DE/WM.

Last edited by fancypiper; 12-29-2003 at 05:22 PM.
Old 12-29-2003, 05:17 PM   #3
LQ Guru
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
I don't think blackbox comes with redhat. You will have to go and install it,
once you do , find where it is located with
whereis blackbox
and put
exec /path/to/blackbox
at the top of your .xinitrc file in your home directory and then startx will bring up blackbox


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
thread switch results in kernel stack switch superstition Linux - General 1 05-18-2005 12:48 AM
Using BlackBox Tusnal Linux - Software 7 07-01-2004 01:18 PM
set up DSL thru SWITCH - winXp connected to SWITCH too husz Linux - Newbie 5 04-22-2004 01:08 AM
Switch to IceWM or BlackBox in Mandrake 9.0 tgardner Linux - Newbie 6 03-23-2003 12:33 PM
Blackbox!? JimmyX01 Linux - Newbie 5 01-09-2002 05:12 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:36 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration