-   Linux - Newbie (
-   -   Trying to install Wine, getting error possibly due to Moblock. (

DemonKyoto 10-03-2008 11:10 AM

Trying to install Wine, getting error possibly due to Moblock.
Running Ubuntu 8.04 and decided to install Wine. When installing it tells me to run "dpkg --configure -a" in the terminal, so I do so and enter my password. Upon doing this, the terminal loads moblock control ( I have moblock installed obviously ). Any way to get this to work? :(

{BBI}Nexus{BBI} 10-04-2008 10:56 AM

How are you trying to install wine? Is it from the source files or from the repositories?

DemonKyoto 10-04-2008 12:53 PM

I started with the instructions here:

I did the following with no problems:

Adding the WineHQ APT Repository:

First, open a terminal window (Applications->Accessories->Terminal). On Debian, you will need to open a root terminal. Then add the repository's key to your system's list of trusted APT keys by copy and pasting the following:

wget -q -O- | sudo apt-key add -

Next, add the repository to your system's list of APT sources:

For Ubuntu Hardy (8.04):
sudo wget -O /etc/apt/sources.list.d/winehq.list

Then update APT's package information by running 'sudo apt-get update'.
I then clicked on the link to apt://wine and tried to download it from the Add/Remove option, when I do so, I get this with both methods.


E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
So I entered "sudo dpkg --configure -a" and entered my password when prompted, at which point it launched the Moblock control configuration in the terminal.

Hope this helps hehe.

Edit: seems anything I try to install now, will give me that same error.

All times are GMT -5. The time now is 02:04 AM.