LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-05-2016, 12:52 PM   #1
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Rep: Reputation: 0
Trying to install/uninstall rpms


Hi,

First command says , conflicts
Second command says , nothing.
Third command says, no rpms (oracleasm*) installed.

How to remove installed rpms completly ?

PHP Code:
# rpm -ivh oracleasm-support-2.1.7-1.el4.i386.rpm
warningoracleasm-support-2.1.7-1.el4.i386.rpmV3 DSA signatureNOKEYkey ID b38a8516
Preparing
...                ########################################### [100]
        
file /usr/lib/oracleasm/oracleasm-Xshlib from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-candidate-p from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-clean-disk from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-deletedisk from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-get-driver from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-instantiate-disk from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-querydisk from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-read-label from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-reload-partitions from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-renamedisk from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-scan-partitions from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-update-driver from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-update-driver-uln from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/lib/oracleasm/oracleasm-write-label from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/sbin/asmscan from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/sbin/asmtool from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4
        file 
/usr/sbin/oracleasm from install of oracleasm-support-2.1.7-1.el4 conflicts with file from package oracleasm-support-2.1.4-1.el4 

PHP Code:
# rpm -qa | grep oracleasm-support-2.1.7-1.el4.i386.rpm 
PHP Code:
# rpm -e oracleasm-support-2.1.7-1.el4.i386.rpm
errorpackage oracleasm-support-2.1.7-1.el4.i386.rpm is not installed 
Quote:
# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 8)
Thanks in advance.
 
Old 02-05-2016, 01:03 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
- RHEL 4 is EOL. Please move to newer platform.
- Why install something when you should update?
 
Old 02-05-2016, 01:09 PM   #3
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Original Poster
Rep: Reputation: 0
Hi,

I know RHEL 4.8 is old.
Please come to my exact error. why it was coming /how to resolve it ?

Last edited by Joy Stick; 02-05-2016 at 01:10 PM.
 
Old 02-05-2016, 01:24 PM   #4
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by Joy Stick View Post
why it was coming /how to resolve it ?
Hi....

Does downloading and installing the package here help?

EDIT: Looks like I didn't catch the full nature of the question, my apologies if this didn't work.

Regards...

Last edited by ardvark71; 02-05-2016 at 01:33 PM. Reason: Added information.
 
Old 02-05-2016, 01:29 PM   #5
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
to remove an rpm:
Code:
rpm -e <name_of_rpm>
# I believe.

I and some others around here may not support EOL Software especially when the person at the helm doesn't know basic rpm commands.

Just a Heads Up.
 
Old 02-05-2016, 01:36 PM   #6
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Original Poster
Rep: Reputation: 0
yes.
What was wrong exactly ?

PHP Code:
# uname -a
Linux RAC-SERVER1 2.6.9-89.EL #1 Mon Apr 20 10:23:08 EDT 2009 i686 i686 i386 GNU/Linux 
http://www.oracle.com/technetwork/se...l4-092650.html



PHP Code:
Drivers for kernel 2.6.9-89.EL
oracleasm
-2.6.9-89.ELxenU-2.0.5-1.el4.i686.rpm 
oracleasm
-2.6.9-89.ELsmp-2.0.5-1.el4.i686.rpm 
oracleasm
-2.6.9-89.ELhugemem-2.0.5-1.el4.i686.rpm 
oracleasm
-2.6.9-89.EL-debuginfo-2.0.5-1.el4.i686.rpm 
oracleasm
-2.6.9-89.EL-2.0.5-1.el4.i686.rpm 

Library 
and Tools 
oracleasm
-support-2.1.7-1.el4.i386.rpm 
oracleasmlib
-2.0.4-1.el4.i386.rpm 
Thanks

Last edited by Joy Stick; 02-05-2016 at 01:42 PM.
 
Old 02-05-2016, 01:48 PM   #7
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
as a guess, I'd focus on removing oracleasm-support-2.1.4-1
before installing oracleasm-support-2.1.7-1.el4.i386.rpm

I haven't done Oracle in 16 years, sorry.

As another guess, I'd say you have to remove the 2.1.4 rpm ("conflicts with...")
for any 2.1.7 rpm you intend to install.
Code:
rpm -qa | grep -i oracleasm | grep 2.1.4
will show you a list of 2.1.4 oracleasm packages.

See also http://www.oracle.com/technetwork/to...ll-082632.html

Last edited by Habitual; 02-05-2016 at 02:54 PM.
 
Old 02-05-2016, 01:49 PM   #8
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Original Poster
Rep: Reputation: 0
PHP Code:
# rpm -ivh oracleasm-2.6.9-89.EL-2.0.5-1.el4.i686.rpm
warningoracleasm-2.6.9-89.EL-2.0.5-1.el4.i686.rpmV3 DSA signatureNOKEYkey ID b38a8516
Preparing
...                ########################################### [100%]
        
package oracleasm-2.6.9-89.EL-2.0.5-1.el4 is already installed 
PHP Code:
[root@RAC-SERVER1 rpm1]# rpm -ivh oracleasm-2.6.9-89.EL-debuginfo-2.0.5-1.el4.i686.rpm
warningoracleasm-2.6.9-89.EL-debuginfo-2.0.5-1.el4.i686.rpmV3 DSA signatureNOKEYkey ID b38a8516
Preparing
...                ########################################### [100%]
        
package oracleasm-2.6.9-89.EL-debuginfo-2.0.5-1.el4 is already installed 
PHP Code:
[root@RAC-SERVER1 rpm1]# rpm -ivh oracleasmlib-2.0.4-1.el4.i386.rpm
warningoracleasmlib-2.0.4-1.el4.i386.rpmV3 DSA signatureNOKEYkey ID b38a8516
Preparing
...                ########################################### [100%]
        
package oracleasmlib-2.0.4-1.el4 is already installed 
[root@RAC-SERVER1 rpm1]# rpm -qa | grep oracleasm*

** NO OUTPUT ** DOES IT MEAN ABOVE RPMS DID NOT INSTALL IN LINUX MACHINE. ??



PHP Code:
[root@RAC-SERVER1 rpm1]# rpm -ivh oracleasm-2.6.9-89.ELhugemem-2.0.5-1.el4.i686.rpm
warningoracleasm-2.6.9-89.ELhugemem-2.0.5-1.el4.i686.rpmV3 DSA signatureNOKEYkey ID b38a8516
error
Failed dependencies:
        
kernel-hugemem 2.6.9-89.EL is needed by oracleasm-2.6.9-89.ELhugemem-2.0.5-1.el4.i686
    Suggested resolutions
:
        /var/
spool/up2datekernel-hugemem-2.6.9-89.EL.i686.rpm 
error: Failed dependencies: -- How do i get all required dependencies ??
 
Old 02-05-2016, 01:51 PM   #9
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Try
Code:
rpm -qa | grep -i oracelasm | grep 2.1.4
instead as it could be named Oracleasm or OracleASM

Last edited by Habitual; 02-05-2016 at 01:52 PM.
 
Old 02-05-2016, 01:53 PM   #10
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Installing Oracle ASMLib - Seen it? Read it?
 
Old 02-05-2016, 01:54 PM   #11
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Original Poster
Rep: Reputation: 0
Habitual
PHP Code:
# rpm -qa | grep oracelasm | grep 2.1.4
** NO output ** 
 
Old 02-05-2016, 01:57 PM   #12
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,392

Rep: Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014
That third command is just plain wrong. "rpm -e" takes a package name (possibly including the version numbers), not a file name. The conflict messages indicate that you have oracleasm-support-2.1.4-1.el4 installed and tried to install version 2.1.7-1.el4. You should be upgrading (-U), not installing (-i).

RHEL 4 is ancient and, unless you are paying extra for extended life cycle support, lacks 4 years of security updates. Even that extended support has only about one more year to run (ends March 31, 2017).
 
Old 02-05-2016, 02:00 PM   #13
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Original Poster
Rep: Reputation: 0
I read it

Then i need to install required rpms then only i can configure as per previous link

What you have shared http://www.oracle.com/technetwork/to...ll-082632.html

I googled and i tried ( but i cannot, so i ask experts)
 
Old 02-05-2016, 02:00 PM   #14
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,392

Rep: Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014Reputation: 2014
Quote:
Originally Posted by Joy Stick View Post
Habitual
PHP Code:
# rpm -qa | grep oracelasm | grep 2.1.4
** NO output ** 
You misspelled "oraclesasm".
 
1 members found this post helpful.
Old 02-05-2016, 02:05 PM   #15
Joy Stick
Member
 
Registered: Dec 2015
Distribution: RHEL 4.7
Posts: 127

Original Poster
Rep: Reputation: 0
PHP Code:
# ls -l
total 701
-rwxrwxrwx  1 root root 132358 Feb  4 07:04 oracleasm-2.6.9-89.EL-2.0.5-1.el4.i686.rpm
-rwxrwxrwx  1 root root   2537 Feb  4 07:04 oracleasm-2.6.9-89.EL-debuginfo-2.0.5-1.el4.i686.rpm
-rwxrwxrwx  1 root root 127800 Feb  4 07:04 oracleasm-2.6.9-89.ELhugemem-2.0.5-1.el4.i686.rpm
-rwxrwxrwx  1 root root 134727 Feb  4 07:03 oracleasm-2.6.9-89.ELsmp-2.0.5-1.el4.i686.rpm
-rwxrwxrwx  1 root root 137461 Feb  4 07:03 oracleasm-2.6.9-89.ELxenU-2.0.5-1.el4.i686.rpm
-rwxrwxrwx  1 root root  13105 Feb  4 07:05 oracleasmlib-2.0.4-1.el4.i386.rpm
-rwxrwxrwx  1 root root  83636 Feb  4 07:05 oracleasm-support-2.1.7-1.el4.i386.rpm 
I wanna install all rpms, please provide me some guide, where i am failing ?

Why error has occured ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rpms will not install or uninstall jginger Linux - Newbie 2 10-13-2004 12:53 PM
mandrake 9.2 won't uninstall rpms storyteller Linux - Software 4 12-11-2003 01:48 PM
RH9 Rpms' uninstall to tgz install... (glib) bkeating Linux - Software 2 10-25-2003 12:18 AM
Cannot uninstall RPMs - (RedHat) Ed Mack Linux - Software 5 01-04-2003 08:34 PM
how to uninstall rpms gonus Linux - Newbie 3 06-14-2002 06:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration