LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Trying to install printer hp 750 all in one (https://www.linuxquestions.org/questions/linux-newbie-8/trying-to-install-printer-hp-750-all-in-one-841551/)

Donnier 10-31-2010 01:56 PM

Trying to install printer hp 750 all in one
 
I am trying to install my hp 750 all in one printer. It worked with windows but when I switched to Linux it will not work now. Any suggestions as how to get it work now?

stress_junkie 10-31-2010 02:16 PM

Install the HPLIP for Linux software.

http://sourceforge.net/projects/hplip/files/

Donnier 11-01-2010 01:47 AM

tried to install but it kept coming up with an error. Give me another suggestion or if you think i messed this up give it to me one more time. Not sure what all the stuff it was talking about. thanks

stress_junkie 11-01-2010 07:54 AM

You will need the HPLIP software if you want to get all of the functions working. Maybe your distribution has that software in its software package management system.

What distribution are you using?

You will also need to install the CUPS software. That is used for all advanced printers. (inkjet, laserjet) That should also be available through your distribution's software package management system.

Once the CUPS software is installed and running you can use a web browser to check on the status of printers and to install new printers. You open your web browser and enter localhost:631 as the address. This will open the CUPS management interface.

Get that much done and report back.

Soadyheid 11-01-2010 11:23 AM

Quote:

tried to install (HPLIP) but it kept coming up with an error.
Have you tried installing HPLIP via the package manager in Mint, Synaptic? I'm running an HP 750 without problem under Ubuntu 10.04.
I've just tried running the printer of a Virtual Mint install under VirtualBox but have failed miserably as I couldn't find the printer :( Another layer of complexity probably doesn't help so I'm not going to pursue it further. Try the package manager though. :)

Play Bonny! :hattip:

frankbell 11-01-2010 08:52 PM

To verify that you have CUPS installed (most distros include it), you can open a browser and go to http://localhost:631. If CUPS is installed, you should see the CUPS interface.

If not, install it, then (re)install hplip.


All times are GMT -5. The time now is 11:38 AM.