-   Linux - Newbie (
-   -   Trying to install Madwifi Driver, asking me to configure Kernel, absolutely lost, (

ETRadix 01-07-2009 03:08 PM

Trying to install Madwifi Driver, asking me to configure Kernel, absolutely lost,
Hi All,

I am trying to install Madwifi 0.9.4 and I get the error ...

[root@localhost madwifi-0.9.4]# make install
/bin/sh: line 0: cd: /lib/modules/ No such file or directory *** /lib/modules/ is missing, please set KERNELPATH. Stop.
[root@localhost madwifi-0.9.4]#

The install file tells me to ...

- Configured kernel sources of the target kernel. Some Linux
distributions provide headers, makefiles and configuration data - it
should suffice.

- Wireless Extensions support (14 or later, 17 preferred) - option
CONFIG_NET_RADIO in kernel .config file.

- Sysctl support - option CONFIG_SYSCTL in kernel .config file.

- Crypto API support - option CONFIG_CRYPTO in kernel .config file (AES
support is used if present, otherwise the AES-CCMP cipher module falls
back to a private implementation).

- gcc of same version that was used to compile the kernel. At least
make sure that the first two version numbers or the compiler are the
same (e.g. it's OK to use gcc 3.4.6 to compile MadWifi if the kernel
was compiled by gcc 3.4.2). Ignoring this rule will cause "Invalid
module format" errors during module load.

Linux 2.4.x kernels starting with 2.4.22 and 2.6 kernels should work
without problems. Due to quick pace of Linux development, there is no
way compatibility with the future 2.6 kernels can be ensured. However,
the latest 2.6 kernel at the time of the release should be expected to

Automatic module loading support (CONFIG_KMOD) is recommended; otherwise,
care will have to be taken to manually load needed modules.

I am new to linux, took me a month just to install Fedora 10, I feel overwhelmed by the learning curve, did not think it would be this hard, can anyone advise,


farslayer 01-07-2009 03:52 PM

I think you are going about this the hard way.. why not just install madwifi from the Fedora repositories..

Configure the repository

Install the madwifi modules

ETRadix 01-07-2009 05:47 PM

Thank You it worked
Thank You farslayer for taking the time to respond, it worked like a charm, I spent the best part of a week trying to get it going, I have just been following directions I found when searching online, they led me to madwifi project.

Thanks Again

Quakeboy02 01-07-2009 07:54 PM

Like I mentioned in the closed thread: isn't ath5k already available to "ath5k" is the replacement for madwifi. It names the device wlan* instead of ath*.

All times are GMT -5. The time now is 12:26 PM.