-   Linux - Newbie (
-   -   trying to install latest java downloaded and saved to desktop (

jakespet 08-10-2008 08:02 AM

trying to install latest java downloaded and saved to desktop
Okay here is just one of my problems. Although, I'm not a complete newby, (just dished MS windows) I am fairly inexperienced on Linux Ubuntu 8.
I just downloaded the latest upgrade of java and followed the directions on how install it, But when I change directories,via cd command, I keep getting the message"no such file or directory exists" It has become a very frustrating experience. But I'm not giving up. I'm hoping some of you good people can give me some help.
B Howard

klearview 08-10-2008 08:12 AM

First, why don't you install java from repositories through synaptic?
Second, describe exactly what you are doing when you are getting "no such file or directory exists" - you are obviously making some very, very basic mistake so please provide what exactly you are typing and what output you are getting.

jakespet 08-10-2008 10:04 AM

I have an application that the author has rewritten in JAVA and I have Alpha tested it with SUSE 10.3. The Beta version I am trying to test on Ubuntu, (My choice of Distros) and apparently the java version I have 1.5_14 does not meet the application requirements, So I downloaded from the new version, at least I think it is, 1.6 to see if I could run it with that version and also to learn how to install from a source other than Synaptic, which I used to install 1.5_14. So as a newby, any help i can get, would be greatly appreciated.
Thank you.
B Howard

klearview 08-10-2008 10:43 AM

Sun Java 1.6 (jre 6) is in repositories - so you can just update to it.

"to learn how to install from a source other than Synaptic" - I don't think there is much value in taking a more complicated approach but fair enough.

Remove whatever Java you have now - be it Sun or GNU (search for gij package). I assume you downloaded a .bin file from Sun's website? If so open terminal and go the directory where this .bin file is (e.g. if you downloaded it to Desktop then 'cd /home/yourusername/Desktop'). Make that .bin file executable ('chmod +x filename.bin'). As root run it ('sudo ./filename.bin'). Follow the prompts, accept T&C etc and you should be done.

Hope this helps.

jakespet 08-10-2008 11:38 AM

This may sound like a dumb question, no, not may, it will, but, if I have java 6 installed and it shows that I do, why does it show me java 1.5_14 when I ask for version No. in terminal? I thought perhaps that's why the beta version of the program I am testing wouldn't work. Perhaps there's another reason.
Thank you for your help. You Linux guys are great.

klearview 08-10-2008 01:02 PM

If, when you put 'java -version' it gives you version 1.5 it simply means you haven't removed 1.5 yet.

I hope you installed 1.5 through you package manager (Synaptic or whatever) and not through self-extracting archive (.bin file from Sun's website). If you did it should be easy to remove it. Let's search for the installed packages first - 'dpkg -l | grep sun' . This will spit out some sun-java5 packages. Then do 'sudo apt-get remove packagename' .

jakespet 08-10-2008 02:40 PM

I just received an email from the author of the program I am beta testing and it seems I have the have version of java needed to run the application. The problem may be something called "locking assertion failure" It seems some debian based Linux including Ubuntu 8+ has a problem with certain java apps. Something to do with drivers. He sent me a web page and the possible soulution, but I have no idea where to start. I tried finding wgat i wanted through add/remove, search in Synaptic and I have no clue what to do.
I hope it doesn't take me as long to learn Linux as it did to learn Windows .He sent a link to my problem and the possible solution. I really do appreciate your input

jakespet 08-10-2008 02:49 PM

Sorry about these extra posts. See. I thought I lost them. See I really am a newby

jakespet 08-10-2008 03:02 PM

I just recieved an email from the author of the program i am beta testing and the problem mayhave nothing to do with the version. he tells me I have the minimum java requirement, but may be something called "Locking assertion Failure" Some Debian based systems including Ubuntu 8+ seems to have some kind of conflict with java, has someting to do with certain drivers. I forwarding to you the link he sent me and the possible solution, but I have no idea what to do. I have tried working from the terminal, add/remove and synaptic. But being a very novice Newby, I have no idea what to do. I am forwarding the web address to you and maybe you can give me some input, cause I'm like duck pretending to be an eagle. I got the "feathers" but I still quack!
I knew there was another reason I like Linux. IT'S THE PEOPLE!!

klearview 08-10-2008 03:40 PM

Here is what to do (well, according to that link anyway - I have no idea whether it will actually help).

In terminal:

cd /usr/lib/jvm/java-6-sun-
sudo cp
sudo sed -i 's/XINERAMA/FAKEEXTN/g'

(On line 2 there I'm just making a back-up copy - "just in case")

I have no idea if that will work or what the bug is but I hope it helps.

jakespet 08-10-2008 08:17 PM

That did not solve my problem but I do appreciate your help. The author tells me that if I go back Ubuntu 7+ more than likely that will solve my problem, But after some consideration, I'll think I'll stick with this one. I have two hard drives and one of them just went bad and has to be replaced, so when I replace in a few days, I'll run Gutsy Gibbon and see if the problem still exists. I thank you for your help Klearview and maybe someday I'll get to Scotland and meet you.
Again Thank you.

/usr/darien 08-17-2008 12:12 AM

This is how I update Java on RHEL/Fedora based systems.

  • Download latest Java Runtime. As of now, jre-6u7-linux-i586.bin for 32bit systems.
  • Su to root
  • Mv the downloaded file to /usr/lib
  • Cd to /usr/lib
  • Make sure the .bin file is executable. If not, invoke a chmod +x jre-6u7-linux-i586.bin
  • Execute ./ jre-6u7-linux-i586.bin from within /usr/lib.
  • NOTE: The actual Java exectuble will be located in /usr/lib/jre1.6.0_07/bin
  • Cd /usr/bin
  • If there is an existing java executable or symbolic link, rename to something else. For example, "mv java java.old"
  • Create a symbolic link to new, updated java execuable by issuing ln –s /usr/lib/jre1.6.0_07/bin/java /usr/bin/java.
  • To check, type java –version.

All times are GMT -5. The time now is 07:14 PM.