LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2013, 02:50 AM   #1
kedarp
Member
 
Registered: Jul 2012
Distribution: Ubuntu
Posts: 197
Blog Entries: 3

Rep: Reputation: 23
Trying to install gimp


Hello,

I have a tar of the gimp 2.8 setup. When I try to install it, I get the
following dependency problem -

Code:
#./configure

Here are the last few lines of o/p - 

checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for iso-codes... yes
checking for BABL... no
configure: error: Package requirements (babl >= 0.1.10) were not met:

No package 'babl' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BABL_CFLAGS
and BABL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Now when I find the package in Synaptic, I get a package -

libbabl-0.0-0
Dynamic, any to any, pixel format conversion library

But after I install this package I again get the same o/p.
 
Old 01-15-2013, 03:06 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

For the version of Gimp you're installing the version of the babl package needs to be higher or equal to 0.1.10:
Code:
Package requirements (babl >= 0.1.10) were not met:
And why are you installing from source? Doesn't the version your package manager/repository offers suit your needs?

Kind regards,

Eric
 
2 members found this post helpful.
Old 01-15-2013, 04:09 AM   #3
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7/10
Posts: 879

Rep: Reputation: 113Reputation: 113
If your using ubuntu 10.10 still I would recommend you to upgrade for the latest. However you can run

# sudo apt-get install gimp

which will installed a prepacked version of gimp. If you don't wish to upgrade and still want the latest you can try getting the packages from a later ubuntu repo and install them manually or recompile them from source. If you decide to compile them I would suggest you learn how to pack them into a .deb.
 
1 members found this post helpful.
Old 01-15-2013, 06:53 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,684

Rep: Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286Reputation: 3286
Quote:
Now when I find the package in Synaptic, I get a package -

libbabl-0.0-0
Quote:
Package requirements (babl >= 0.1.10) were not met:
The missing part is babl.pc : A package config file.

To use babl for compilation, a complete "libbabl" is required.
I.e. you are missing the package libbabl-0.0-0-dev ,
providing /usr/lib/pkgconfig/babl.pc , etc. etc.

-
 
Old 01-15-2013, 07:12 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,133
Blog Entries: 2

Rep: Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839Reputation: 4839
And if you find the needed version of libbabl your next stop will be GEGL and after that you will find out that you need a newer version of libglib and this is where it becomes hairy, because libglib is widely used, especially on Gnome system, so updating libglib can break many applications.
If you want to use GIMP 2.8 upgrading your distibution to recent version is the easiest way to go. Which is recommended anyways if you are still running the totally unsupported and therefore insecure Ubuntu 10.10.
 
1 members found this post helpful.
Old 01-15-2013, 07:20 AM   #6
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Debian 7 / Crunchbang 11
Posts: 229

Rep: Reputation: 41
Thumbs up

Quote:
Originally Posted by EricTRA View Post
And why are you installing from source? Doesn't the version your package manager/repository offers suit your needs?
I think it's an error from the OP...
 
Old 01-15-2013, 08:53 AM   #7
kedarp
Member
 
Registered: Jul 2012
Distribution: Ubuntu
Posts: 197
Blog Entries: 3

Original Poster
Rep: Reputation: 23
The latest version available in Synaptic is 0.0.22. So it is better to install it from the repository
than falling in to the dependency loop.
Thanks for the replies btw.
 
Old 01-15-2013, 08:55 AM   #8
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 5,458
Blog Entries: 12

Rep: Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905
You're not going to be able to get gimp 2.8 installed on Ubuntu versions earlier than 12.04. According to your user info, you have 10.10.

http://<br /> http://askubuntu.com/...gimp-2-8<br />

"Ubuntu versions prior to 12.04

Currently there is no method to install Gimp 2.8 on any version below 12.04.

In terms of is it possible ...

Unlikely for the following reason:

The dependencies of the latest versions of Gimp require a-lot of the latest underlying libraries that you will not find by default in any version below 12.04. Thus, you will need to recompile and rewrite portions of the code to get it to compile. The further away you get from 12.04, the larger the change required."
 
1 members found this post helpful.
Old 01-15-2013, 09:12 AM   #9
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Debian 7 / Crunchbang 11
Posts: 229

Rep: Reputation: 41
(Sorry by replying to a solved thread)

Official support for Ubuntu 10.10 ended in April/2012: http://fridge.ubuntu.com/2012/04/10/...april-10-2012/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: GIMP Painter And GIMP Paint Studio Transform GIMP Into The Ultimate Painting Tool LXer Syndicated Linux News 0 02-08-2011 05:40 PM
Trying to install gimp Brushes to /usr/share/gimp/2.0/brushes but permission denied?? iTtrick Linux - Newbie 9 07-08-2009 06:33 AM
Trying to install Gimp Siarosh Linux - Newbie 1 01-16-2009 03:21 PM
trying to install GImp 2.0 allelopath Linux - Software 5 11-14-2004 12:25 PM
need gimp install how 2's dejan_j Linux - Software 4 05-10-2003 01:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration