LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Trying to get Vodafone dongle to work with Ubuntu. (https://www.linuxquestions.org/questions/linux-newbie-8/trying-to-get-vodafone-dongle-to-work-with-ubuntu-881067/)

GandTPratt 05-16-2011 04:54 PM

Trying to get Vodafone dongle to work with Ubuntu.
 
Hi, I am trying to get my daughters Ubuntu Laptop to connect to the internet via a Vodafone USB dongle.

I have managed to get the modem itself to connect to Vodafone using the Sakis3G script (brilliant), however once connected the laptop will not pass data through this connection. i.e. when I select "Vodafone prepaid" as a network connection, the little pop up comes up and says GSM no connected?

When I get a connection information from Sakis, it gives an IP address and even had a tiny bit of throughput, however I do not know how to tell it to use the vodafone thingy.

Could someone please advise what I need to do next?

Thanks.

Graham

xzcallaway 05-16-2011 05:49 PM

There are instructions on how to configure Vodafones with Ubuntu here:
http://www.geekology.co.za/blog/2009...nty-jackalope/

audragon 05-16-2011 09:39 PM

More instruction here
 
Try this one:
http://www.howtoforge.com/vodafone_m...d_driver_linux

There is also a linux version of Vodafone Mobile Connect software available - including a ubuntu package:
http://www.betavine.net/bvportal/resources/datacards
and here are the actual deb files:
https://forge.betavine.net/frs/?group_id=12

You need the vodafone-mobile-connect_2.25.01-1_all.deb and ozerocdoff_0.4-2 deb file for your architecture (32-bit/64-bit).
usb-modeswitch is included in Ubuntu 11.04 - not sure about 10.10. The vodafone-mobile-connect_svn file seem to be older versions. I got up and running with just the ozerocdoff and vodafone-mobile-connect.

I includes a gui, and usage indicator - so is similiar to the windows version.

Hope this helps.

GandTPratt 05-18-2011 08:59 PM

Thanks. Problem solved.
 
Hi,

Thanks for all the info.

I tried a few things then noted that the newer version 11.04 apparently does this well so....... a couple of hours later....
11.04 downloaded and installed......

Logged in AND using the connection.

My daughter and I thank you sincerely.

Graham

audragon 05-20-2011 07:51 AM

Happy to be of help
 
Happy to help.


All times are GMT -5. The time now is 09:38 AM.