LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-30-2017, 02:24 PM   #1
heckyeahcool
LQ Newbie
 
Registered: Oct 2017
Posts: 1

Rep: Reputation: Disabled
Question Trying to downgrade Apache 2.4 to 2.2 on RHEL7 for QA group.


AS the title says, I received a weird request from our QA group and have been trying to downgrade/install apache 2.2.* on RHEL 7.3. I got this working by installing from source, however, when running systemctl status httpd, it says httpd.service is not present and did not install as a normal yum installation would.

I then tried installing httpd 2.4 via yum, then mounted the RHEL 6.8 dvd and tried downgrading to Apache 2.2 that way but got a lot of errors.

Is this even possible what I am trying to do?

Code:
--> Finished Dependency Resolution
Error: Package: apr-util-1.3.9-3.el6_0.1.i686 (InstallMedia)
           Requires: libdb-4.7.so
Error: Package: glibc-2.12-1.192.el6.i686 (InstallMedia)
           Requires: glibc-common = 2.12-1.192.el6
           Installed: glibc-common-2.17-157.el7.x86_64 (@anaconda/7.3)
               glibc-common = 2.17-157.el7
           Available: glibc-common-2.12-1.192.el6.x86_64 (InstallMedia)
               glibc-common = 2.12-1.192.el6
Error: Package: httpd-2.2.15-53.el6.x86_64 (InstallMedia)
           Requires: httpd-tools = 2.2.15-53.el6
           Installed: httpd-tools-2.4.6-45.el7.x86_64 (@InstallMedia)
               httpd-tools = 2.4.6-45.el7
           Available: httpd-tools-2.2.15-53.el6.x86_64 (InstallMedia)
               httpd-tools = 2.2.15-53.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Last edited by heckyeahcool; 10-30-2017 at 02:26 PM.
 
Old 10-30-2017, 02:57 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,217

Rep: Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962Reputation: 5962
Quote:
Originally Posted by heckyeahcool View Post
AS the title says, I received a weird request from our QA group and have been trying to downgrade/install apache 2.2.* on RHEL 7.3. I got this working by installing from source, however, when running systemctl status httpd, it says httpd.service is not present and did not install as a normal yum installation would.

I then tried installing httpd 2.4 via yum, then mounted the RHEL 6.8 dvd and tried downgrading to Apache 2.2 that way but got a lot of errors. Is this even possible what I am trying to do?
Code:
--> Finished Dependency Resolution
Error: Package: apr-util-1.3.9-3.el6_0.1.i686 (InstallMedia)
           Requires: libdb-4.7.so
Error: Package: glibc-2.12-1.192.el6.i686 (InstallMedia)
           Requires: glibc-common = 2.12-1.192.el6
           Installed: glibc-common-2.17-157.el7.x86_64 (@anaconda/7.3)
               glibc-common = 2.17-157.el7
           Available: glibc-common-2.12-1.192.el6.x86_64 (InstallMedia)
               glibc-common = 2.12-1.192.el6
Error: Package: httpd-2.2.15-53.el6.x86_64 (InstallMedia)
           Requires: httpd-tools = 2.2.15-53.el6
           Installed: httpd-tools-2.4.6-45.el7.x86_64 (@InstallMedia)
               httpd-tools = 2.4.6-45.el7
           Available: httpd-tools-2.2.15-53.el6.x86_64 (InstallMedia)
               httpd-tools = 2.2.15-53.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Possible? Sure. Worth the time? Nope, not when you can downgrade using yum:
https://access.redhat.com/solutions/29617

..but only if you're paying for RHEL (you are, right??) But I'd first ask your QA team what they were trying to accomplish and why. Just blindly doing something like this may not be a good thing. If they're just wanting to test some pages with an old version of Apache, it would be more worthwhile to spin up a virtual box to let them play on.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suma web application install issue - RHEL7 - Apache 2.4.6 linuxproject48 Linux - Server 2 11-23-2016 03:28 PM
Unable to install RHEL7 KVM onto RHEL7 desktop redhatprat Red Hat 10 02-18-2015 04:44 AM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 06:30 AM
Downgrade apache 2 to 1.3 ssl problems... jimieee Linux - Software 1 12-19-2003 05:09 AM
Apache 2 -> 1.3 How to downgrade? RH8 pkdunn Linux - Software 0 07-13-2003 01:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration