-   Linux - Newbie (
-   -   Trying to accomplish something which I thought was pretty basic.... (

a5150a 08-02-2003 07:01 PM

Trying to accomplish something which I thought was pretty basic....
Well, I'm trying to uzip a file, filename is GCT_opera_2003-3-3.gz.... when I dbl click it, gzip opens up and tries to unzip the package... then it comes back and says it's not in gzip format. Iv'e tried tar -xzvf (even though there's no tar in the filename), unzip -xzvf, etc. in a terminal, also to no avail. This is all so new to me. Any suggestions? I've done a few searches already, and haven't turned up anything....:confused:

slakmagik 08-02-2003 07:06 PM

Try 'file GCT_opera_2003-3-3.gz' and see if it returns anything useful.

a5150a 08-02-2003 07:20 PM


Originally posted by digiot
Try 'file GCT_opera_2003-3-3.gz' and see if it returns anything useful.
ok.. did that, now it says "x86 boot sector".....

what I'm trying to end up with is a .img file that can be loaded onto a CF card for booting a system.... does this mean I've just got to convert the 'gz file to .img? If so, how can this be done?

slakmagik 08-02-2003 07:26 PM

Hm. I have no familiarity with what you're doing but I suspect you could just try renaming it. If it didn't return anything about compression, it's probably not compressed. And it's possible it doesn't even need that. Maybe it's just usable as is? I could be way wrong here, though.

I mean, you would 'dd' it to this device, right? So just 'dd if=whoozitz.gz' etc might work.

a5150a 08-02-2003 07:34 PM

Yeah, I tried to rename it as an .img file, then dd'd it to the CF card. ended up with a bunch of folders that had incorrect file sizes and such... lots of 2GB sizes, etc... this is on a 128MB flash card. The original .gz file was about 30mb. I'm guessing something may be wrong there. :confused: :scratch: Now, to view this, I mounted the flash drive, then just dbl clicked it to view... should I be viewing in another fashion?

slakmagik 08-02-2003 07:40 PM

Yeah - you mentioned 'double-clicked' to unzip and now 'double-clicking' to view - what are you viewing with? If it wrote directories to the card then that sounds like it's at least partly right. You say this is to boot with - have you tried it? I'm going to have to bow out because I really have no idea why directories would show up as two gigs. Like I say, I don't know anything about flash cards - I just knew about identifying certain kinds of files. :) But good luck with it.

a5150a 08-02-2003 07:46 PM

I appreciate your help.. as far as the 'double clicking' goes, I'm a Windows guy..... double click everything. Guess I'm just expecting a program to be associated with the file automatically. When I double clicked the .gz file, gzip opened automatically. Once the file was dd'd to the cf card, I mounted the directory (/mnt/flash), then dbl clicked it on the desktop. It opened right up, but the file names were all screwy and the file sizes were wrong. In any case... thanks for the help! I'll keep pluggin' along at it.... figure it out sooner or later! :study:

All times are GMT -5. The time now is 03:17 AM.