LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Troubleshooting autofs... (https://www.linuxquestions.org/questions/linux-newbie-8/troubleshooting-autofs-886795/)

trist007 06-16-2011 09:30 PM

Troubleshooting autofs...
 
I have /var/ftp/pub on Computer A being exported via nfs. I'm running defaults, master map file is defined as auto.master in /etc/sysconfig/autofs.

On Computer B, I can manually mount the nfs share with no problem. However, it doesn't seem to mount with autofs.

I'm running Centos 5.5 on Computer B. I have the following configs
Code:

/etc/auto.master
/misc  /etc/auto.misc

Code:

/etc/auto.misc
pub  -fstype=nfs  computerA:/var/ftp/pub

Now /misc does not exist on computer B. I run service start autofs. It starts up no problem. Yet when I go to /misc, there's nothing in there. I temporarily disabled selinux as well as iptables to help with troubleshooting. Any ideas of what else to check? I mean I can manually mount the share in compouter B no problem.

trist007 06-16-2011 10:40 PM

Does autofs require NIS to work?

chrism01 06-16-2011 10:41 PM

iirc, the default is lazy mounting ie it won't 'appear' until you go all the way into the target dir ie /misc/pub ( not just /misc )
http://www.linuxtopia.org/online_boo...ig-autofs.html

PS @trist007: NIS is not reqd

trist007 06-16-2011 10:59 PM

Ah, haha, I see. Thanks chrism01.

Tinkster 06-16-2011 11:08 PM

Quote:

Originally Posted by trist007 (Post 4388125)
I have /var/ftp/pub on Computer A being exported via nfs. I'm running defaults, master map file is defined as auto.master in /etc/sysconfig/autofs.

On Computer B, I can manually mount the nfs share with no problem. However, it doesn't seem to mount with autofs.

I'm running Centos 5.5 on Computer B. I have the following configs
Code:

/etc/auto.master
/misc  /etc/auto.misc

Code:

/etc/auto.misc
pub  -fstype=nfs  computerA:/var/ftp/pub

Now /misc does not exist on computer B. I run service start autofs. It starts up no problem. Yet when I go to /misc, there's nothing in there. I temporarily disabled selinux as well as iptables to help with troubleshooting. Any ideas of what else to check? I mean I can manually mount the share in compouter B no problem.

Auto-mounted directories don't appear until needed. A simple way
for you to deal with this would be to
ln -s /misc/pub /pub


As soon as you 'cd /pub' (or, obviously, /misc/pub), it will get
mounted, and you can use it to your hearts content (if the other
parameters in e.g., the share are correct). And yes, tab-expansion
won't work for this ;}


Cheers,
Tink


P.S.: Got to learn not to click "quote" and walk away :D


All times are GMT -5. The time now is 02:16 PM.