LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Trouble with apt-get gnash in Gutsy 7.10 on thinkpad (https://www.linuxquestions.org/questions/linux-newbie-8/trouble-with-apt-get-gnash-in-gutsy-7-10-on-thinkpad-613314/)

EXiMiOUS 01-13-2008 01:50 PM

Trouble with apt-get gnash in Gutsy 7.10 on thinkpad
 
Hi,
I'm new to administrating my own GNU/Linux machine. I've recently installed Gutsy Gibbon 7.10 on my think pad, and I'd like to start installing some programs, particularly Gnash.

I tried downloading Gnash, cd'ing to that directory and typing "./configure" I got a ton of responses while config was checking for dependencies, many of which it answered "no" including gawk. I was later told that compiling Gnash from source is notoriously difficult and unnecessary.

So I tried using apt-get instead. I typed "apt-get update" and got this:

Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release amd64 (20071016) gutsy/main Translation-en_US
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release amd64 (20071016) gutsy/restricted Translation-en_US
Reading package lists... Done

Then I tried "apt-get install gnash" and got this:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package gnash

I have a feeling that I'm missing something fairly simple. Do I need to sign up with something to use apt-get? Tell my machine to accept downloads via apt-get? Or maybe there wasn't any new updates and gnash is actually not available.

At any rate, I'd appreciate any help or suggestions.
Cheers,
Deb

PS I tried posting this half an hour ago and something glitched and disappeared that attempt. If the other post mysteriously appears, then I'm sorry in advance for the double-post.

jay73 01-13-2008 01:57 PM

Well, you need to specify the proper name of the program if you want it to be recognized. I don't really know what that would be in this case but there are options to find out: you can simply use the synaptic GUI to search and install it or you can use one of the dpkg or aptitude commands to get information about the name and contents of a package. Just use the man dpkg or man aptitude commands to read more.

EXiMiOUS 01-13-2008 02:35 PM

Thanks for the speedy response!

The gui def. did an update and *appeared* to download Gnash but I can't figure out what it's done with it. I'll try reading up on dpkg to see if I can get it going that way.


All times are GMT -5. The time now is 01:25 PM.