-   Linux - Newbie (
-   -   Trouble setting up WiFi on Suse 9.3 (

bnj 04-29-2005 03:04 AM

Trouble setting up WiFi on Suse 9.3

I am having trouble setting up the WiFi connection on my new PC, running SuSE Linux 9.3

The PC is a Desktop PC (not a laptop).
The WiFi card is a
"Zyxel 802.11g Wireless PCI Adapter, Wireless g+ PCI Adapter, G-360"
(These are the things you can see on the box in which the card was sold to me).

YaST detects
"Tekram Technology Co., Ltd ACX 111 Mbps Wireless Interface Configured with DHCP
Device: wlan-bus-pci-0000:00:09.0"

I have configured YaST this way:
Automatic Address Setup (via DHCP)
Host Name: pcblb
Domain Name:
Change Host Name via DHCP
Name Server 1:
Subnet mask:
Domain Search 1:
Routing default gateway: 192.168.01
Encryption: shared key, hexadecimal. Plus I have entered the key, of course.

When I click on "Finish" after the configuration of the card, KInternet runs and does not display any error.

I know the Network works, because I have another computer using it (A Macintosh iBook, Mac OS X). (And I have of course compared the setup of my PC with the one of my iBook).

But after setting it all up, on the terminal, I get:
> ping
connect: Network is unreachable
> ping www dot google dot com (*)
ping: unknown host www dot google dot com (*)


So here is my question: does anyone have a hint about what I could have missconfigured? Is there any more configuration I need to do?
Or, maybe an easier question: what can I check? Saying "Connection to the internet does not work" is very vague. It could be due to many things, I assume. What are these things? What (and how) could I proof?

Thank you very much in advance,

Benjamin - The guy who is looking forward to having a working internet connection on his Linux PC.

I have actually typed this URL in the "normal" way in the terminal, but linuxquestions does not let me enter a URL before I post 5 posts. This is only my third or fourth on these forums.

JoeUser11 04-29-2005 09:24 PM

I had the same problem as you. You know long it took me to fix it? 2 weeks. You know how I eventually fixed it? Bought a nice ethernet cable. It'll be wasting $30, but it is just so much easier. If you really want wireless, by all means go for it (it'll be a great learning experience). But if you're just looking for internet connection, you might want to just avoid the headache.

DmD 04-30-2005 12:56 AM

Some wireless NIC cards don't work under Linux unless you do alot of configuartion. I tried for 3 hours to setup my wifi card for my desktop and I finalyl decided to use my ethernet connection. Much less work..just plug it in and you're connected ;x

craigs80 05-10-2005 04:00 PM

May fix your problem, worked for me.
In YaST, Network Devices, Network Card. Click on your card then click the change button.

Remove your wireless network card from the list then add it again but this time click on the PCMCIA check box, yes i know it isnt a PCMCIA wireless card but this fixed the problem for me. so it should be something like this:



I ended up just leaving the mac address blank it picked everything else up, except the WEP key, obviously!

Just a thought as i dont think a network cable is a very good answer! gotta try these things.

bnj 05-23-2005 12:41 PM

Thank you craig for your answer. I tried to do what you said but it did not work. Could you please describe more precisely what you did?
By the way, do you use the same WiFi card as I do?

i opened YaST -> Network Devices -> Network Card -> Change.
Then I get the window "Network card configuration overview".
I deleted everything I had in there.
Clicked on "Add" and chose:
- Device Type : Wireless
- Checked the box "PCMCIA"
- The configuration name automatically became bus-pcmcia
- All other menus, checkboxes, etc became grey.
I clicked on Next.
In the panel "Network Address setup", I left everything as is (DHCP).
In the panel "Network card configuration", I just entered the network name and left the rest as is (My network is unencrypted).

Then I clicked on finish.

In a terminal, i pinged (my router) and got the message "Network unreachable".

Can you see what I have done wrong?

Thank you and best regards,


bnj 05-27-2005 03:24 AM

Good News
The card suddenly works.
I do not know exactly why. But yesterday, YaST Online Update downloaded a package that had something to do with wireless lan. I cannot remember the name of the package. Today, when I turned my computer on, the card worked (with the automatic configuration, not this pcmcia trick).
So I guess that, if you have the latest version of SuSE, with all the patches installed, this card will be supported by your system. This is a good news for linux-friendly people, in my opinion.

Now, I do not know what I will do with the D-Link WiFi USB adapter that I have ordered the day before yesterday (and paid allready)...

Best regards,


craigs80 05-31-2005 12:28 PM

Nice One
Glad that you stuck with it and got it working. There is a few wireless lan updated drivers for certain chipsets, sounds like you have downloaded the newest ones.

You said that you had an unsecure wireless network, bit of advice (not a good idea!) you should program at least a wep passphrase. Otherwise you will be sharing your internet connection with tonnes of other people down your road.

bnj 05-31-2005 04:26 PM

Thank you for your advice. I have tried to set a WEP passphrase this afternoon, but with no success. Probably I have checked the wrong checkbox or something like that. I will look a bit deeper into it when I have time. Meanwhile, I guess I will be what some call a "hot spot" ;-)



All times are GMT -5. The time now is 05:39 PM.