LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Trouble: mounting, linking, permissions. (https://www.linuxquestions.org/questions/linux-newbie-8/trouble-mounting-linking-permissions-283543/)

crackery 01-28-2005 08:12 PM

Trouble: mounting, linking, permissions.
 
Hi. I am also a newbie to linux.

I installed Ubuntu a couple of days ago, and I've been struggling to learn ever since.

I have a problem with "linking."

I have 4 HD partitions.

hda1 ( 5 GB) ---> / ---> Linux system files. (type: reiserfs)
hda6 (28 GB) ---> /local1 ---> storage: personal documents. (type: reiserfs)

hdb1 (85 GB) ---> /local2 ---> storage: multimedia files. (type: jfs)
hdb2 (31 GB) ---> /local3 ---> storage: anything else. (type: reiserfs)


The problem is that I don't seem to be able to gain access to those folders (local1, local2, local3). For example, when I try to download a file into local3 directory, an error message pops up and it says "Cannot create file. Directory /local3 is not writable."

I added my account to the group of the "root," and chmod 775 to local3. and then I was finally able to save a file in local3 directory. but I found out that the subdirectories in local3 weren't still writable. and even after I chmod 775 to the subdirectory of local3, I could not save a file in the subdirectory for some reason.

I came across all these trouble in the first place while trying to create "shortcuts" to those directories on my desktop.

is there a way? I tried the "ln -s local3 /local3" but I guess i did it wrong. it did not work.

Should I have mounted them under $home when I first installed linux, like $home/local1, $home/local2, and such?

If i want them on my desktop, should i have mounted them /desktop/local1 ... ?


please help.

btmiller 01-28-2005 08:36 PM

What does "ls -ld /local1 /local2 /local3" show? Also can you post your /etc/fstab so we can see how those partitions are mounted?

crackery 01-28-2005 09:03 PM

Quote:

Originally posted by btmiller
What does "ls -ld /local1 /local2 /local3" show? Also can you post your /etc/fstab so we can see how those partitions are mounted?
After executing that command, it shows,

drwxr-xr-x 3 root root 48 2005-01-28 16:28 /local1
drwxr-xr-x 2 root root 256 2005-01-28 14:22 /local2
drwxrwxr-x 5 root root 120 2005-01-28 18:45 /local3


by the way, an update:

somehow, I have now gained a full access to local3 and its only subdirectory: downloads.

I don't really know what triggered it. maybe rebooting? but I thought I had tried it after a reboot and still it did not work?

I am getting confused.

also, is it possible to create "shortcuts" to the local3 on my desktop?



Edit: I still can't copy/paste into local1 and local2 directories. I'll chmod 775 to them. and see what happens since I am in the group of "root." and if i'd have to reboot to have the new permissions taken effect.


Edit2: yes! it worked without rebooting!

I have no idea why I had so much trouble with this... :o

now I am gonna try to create shortcuts on my desktop.



All times are GMT -5. The time now is 12:37 AM.