-   Linux - Newbie (
-   -   Trouble installing slackware disk 2 (

Wolfie301 11-29-2010 02:06 PM

Trouble installing slackware disk 2
I am completly new to Linux and managed to download slackware 13.1 iso and burn it to disk 1 and 2.
I installed disk 1 and set the laptop up fine but it could not find disk 2. I can burn again but do i need to burn in a certain format or as an iso? also i do not know how to get linux to read a cd or mount it?
any help appreciated

repo 11-29-2010 02:11 PM

Did you burned 1 iso to 2 cd's, or did you downloaded 2 iso's?
Make sure the md5sum is correct.

Kind regards

repo 11-29-2010 02:11 PM

removed double post due to slow connection

Wolfie301 11-29-2010 03:06 PM

Dont know how to run the iso
I downloaded 2 separate iso's and intend to download the third. I logged into system as root and made a dir called install then mounted the cd iso disk 2.I then did a ls command and it displayed several files which are slacware-13.1-install-d2.iso, slacware-13.1-install-d2.iso.asc,slacware-13.1-install-d2.iso.md5,slacware-13.1-install-d2.iso.txt.
I want to learn linux and am told its hard and to stick with it, i just need to know the commands to install disk 2 and 3 to get me going. I have bought 2 books and subscribed to this site to get assistance.
Any ideas how i can unpack iso disk 2?

tsg 11-29-2010 03:45 PM

It looks like you copied the files to the CD instead of burning the image. What program did you use to make the CDs?

markush 11-29-2010 04:18 PM

Hi Wolfie301 and welcome to LQ,

I don't know if I really understood what you mean. If you have already installed Slackware with disk1 and your system is working, you may install all additional packages with the "installpkg" command.
As far as I understood you managed to mount the isofile and have access to the packages?
So you can subsequently cd into the directories with the packages and execute

installpkg *.txz

mryuck 11-29-2010 04:18 PM

You can mount an iso with out burning it with

mount -o loop Whatever.iso PathToDirectoryYouWant
In your case you could do

mount -o loop slackware-13.1-install-d2.iso install

Wolfie301 11-29-2010 06:10 PM

Probs install disk2 slackware
I have tried suggestions; the last one has been trying to install for about 5 minutes. I navigated by using cd to the /usr/install directory which is a dir that i created and then used the command install slackware-13.1-install-d2.iso /install
as mentioned the cursor has moved down a line and is flashing and the hard drive light is flashing but nothing else seems to be happening. when i do a ls in the install directory the following files are displayed - slackware-13.1-install-d2.iso, slackware-13.1-install-d2.iso.asc,slackware-13.1-install-d2.iso.md5 amd slackware-13.1-install-d2.iso.txt.
the result of my install attempt has just displayed "reading slackware-13.1-install-d2.iso: input/output error
I will try to burn files again using ultraiso any suggestions are most welcome

EDDY1 11-29-2010 07:20 PM

All you need to do is download and burn 1 iso, I went to their site to see what you downloaded.
You only needed to download 1 iso it'e not full package the rest wll install over internet.


It looks like you're running wins7, after downloading go to downs find the iso click burn image.
Do you have enough disc space?
The iso is bootable
check this out it may help you

EDDY1 11-29-2010 07:27 PM


I will try to burn files again using ultraiso any suggestions are most welcome
Wins 7 has it's own iso burner, "burn image".

Wolfie301 11-29-2010 07:37 PM

trouble trying to install 2nd disk slackware 13.1
Thank you Eddy, I am posting on win7 pc but installing on fresh laptop no o/s.disk 1 went fine but could not install disk 2 or 3. therefore i am left with a very basic version of slackware 13.1 and am trying to intall disk 2. I am a new user and am learning through trying to install disk 2. i have to work from command line but that is fine as part of learning the software. I need to know how to either add to the install package i already have or how to install disk 2
thanks for your post

mryuck 11-29-2010 07:53 PM

I believe kde is on disk2.
Disk3 may not be needed.

If you cd to where the slackware-13.1-install-d2.iso is. (I guess the install directory you made)

Then make a new directory called packages.
Then type

mount -o loop slackware-13.1-install-d2.iso packages
cd to the packages directory and you will find the contents of the iso as if you burned a cd.

jmc1987 11-29-2010 08:06 PM

Just a suggestion. If you are having issues after you burned your CD's then maybe you should try downloading the DVD ISO slackware image. I CD will install lots of usefull software

Wolfie301 11-30-2010 05:56 PM

Slackware d2 install problems
Thanks all for post, Mryuck post 12 - i tried your suggestion and got "mount: can't find slackware-13.1-install-d2.iso in /etc/fstab or /etc/mtab"
I dont know what this means or what i should do.
I am presently downloading the whole iso but this time as suggested by post 13 but downloading the dvd and will install that way i have the lot. It would be nice to know the problem and i do feel i am learning all the time - even if it is the hard way. I am also trying to learn through a cbt nugget but that is redhat and i cant follow on my pc all the commands. If anyone knows how else i can learn please help. I also have a massive book which is meagre confusing but slowly it makes a little sense. This is hard to learn but i think i will benefit
thanks all

markush 11-30-2010 06:11 PM


Originally Posted by Wolfie301 (Post 4176295)
Thanks all for post, Mryuck post 12 - i tried your suggestion and got "mount: can't find slackware-13.1-install-d2.iso in /etc/fstab or /etc/mtab"
I dont know what this means or what i should do....

Well, you have to use the whole path to the isofile

mount -o loop /pathtomyiso/slackware-13.1-install-d2.iso /pathtomypackagedirectory/packages
the errormessage only states that it mount could not find the pathes in /etc/fstab (where it looks if the pathes are not clear).

You've done well until here, good luck, Slackware is a great distribution to learn Linux.
Learning by doing is the fastest way to success with Linux.


All times are GMT -5. The time now is 06:26 PM.