LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Trouble installing grub (https://www.linuxquestions.org/questions/linux-newbie-8/trouble-installing-grub-445067/)

rastiazul 05-15-2006 03:15 PM

Trouble installing grub
 
Hello

I need to install grub to dual boot pclinuxos and windows xp. I only have one hd. I just installed the 2 os's, first windows and then linux.
I have been trying to install following this tutorial: http://www.fedoraforum.org/forum/showthread.php?t=975 but only got to this part:
--------------
7) Set the GRUB's root device to the partition containing the boot directory like this:

grub> root (hd0,0)
--------------
When I typed that I got this:

filesystem type unknown, partition type 0x7.

I dont know if it matters but I also have this info from my drive:

Possible partitions are:
Partition num: 0, Filesystem type unknown, partition type 0x7
Partition num: 4, Filesystem type unknown, partition type 0x82
Partition num: 5, Filesystem type ext2fs, partition type 0x83
Partition num: 6, Filesystem type ext2fs, partition type 0x83

I also tried:
find /boot/grub/stage1
Error 15: File not found

Ive been trying to get this working for several days so I would really appreciate any solution. :jawa:

pixellany 05-15-2006 03:44 PM

When you installed PCLinux, did it not give you an option to install a bootloader?

It is not 100% clear whether grub is already installed. Also, where did you get that partition information? (eg where are partitions 1-3? and where is the Windows partition) If you are able to get into Linux somehow, then type "fdisk -l" (as root) and post the results.

Assuming that the PCLinux installer will install grub, then starting over may be the easiest route.

rastiazul 05-15-2006 03:56 PM

PClinux installs lilo by default but lilo doesnt work in my computer. I get the timestamp mismatch error, this due to my type of mobo and having a sata hd. I got the partition information using grub from the fedora rescue cd. Partitions 1-3? no idea. Windows partition? I think type 0x7 is suposed to be ntfs ... I cant get into linux, I can only get into windows. I got into linux once, I dont know why, but one of the several times i rebooted the lilo screen actually came up, and that was when I was able to check (fdisk -l) where the bootloader is= sda1. But im not sure if I was root.
Since Ive been having trouble installinf grub I also tried GAG. With gag I was able to boot into windows but not into linux so i uninstalled it. And now I dont get a lilo error, it just boots directly into windows.

rastiazul 05-15-2006 06:06 PM

Using the pclinuxos livecd i got what you asked:

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2611 20972826 7 HPFS/NTFS
/dev/sda2 2612 38913 291595815 5 Extended
/dev/sda5 2612 2738 1020096 82 Linux swap / Solaris
/dev/sda6 2739 3532 6377773+ 83 Linux
/dev/sda7 3533 38913 284197851 83 Linux


All times are GMT -5. The time now is 05:29 PM.