-   Linux - Newbie (
-   -   Trash can thinks its full (

KBriggs 01-22-2011 08:16 AM

Trash can thinks its full
OK, here is the story: I was emptying a USB key, a few files at at a time, into trash. It was getting pretty full, so I deleted a bunch of files in the trash. Apparently I wasn't watching very carefully, because I deleted something that had only been partially moved into trash.

Needless to say the move operation crashed. However, my trash is now completely empty, but when I try to move something there I get the error message:

"The Trash has reached its maximum size! Cleanup the Trash manually."

So I obviously fubared something. Can anyone get me back on track?

PS: already tried rebooting, and I already tried increasing the maximum space allotted for trash.

PPS: It works again... no idea why though. It just decided it wasn't full anymore. Anyone care to venture an explanation of what happened?

pbpersson 01-23-2011 12:56 AM

What distro and what version? Perhaps it is a known bug?

Weasel War Dance 01-23-2011 05:17 AM

Very similar thing happened to me, I have no idea why. I ended up just setting it so that there was no maximum size, and that seemed to do the trick.

Are you using KDE? That's what I was using when I encountered this problem. I don't remember seeing it in GNOME, but I suppose it could be present there as well.

EDIT: Here's a link to my thread with the same issue. A couple of answers there may be useful to you as well.

ajlewis2 01-23-2011 05:56 AM

Did you try to plug that same usb device back in and empty the trash?

Also look at ~/.local/share/Trash and see if there is anything in any of those directories. When the trash is empty, nothing should be in any of the 3 directories. This is on Ubuntu.

KBriggs 01-23-2011 11:02 AM

I am using Kubuntu, KDE. cat /poc/version gives me: Linux version 2.6.32-27-generic

It seems to have sorted itself out, somehow.

Thanks for the tips. If anyone finds out anything else, let me know :)

All times are GMT -5. The time now is 06:07 PM.