LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2009, 03:34 PM   #1
lazhome
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Rep: Reputation: 0
Transmission not working - Slackware


Hello, I have tried to think of everything here, but I am coming up against a wall here...

Using Slackware 12.0 with KDE 3.5

I installed transmission to /usr/local/bin. I see 4 files total:

751 greg users transmission
751 greg users transmission-daemon
751 greg users transmission-remote
751 greg users transmissioncli

I can log into root and run it fine, but the second i log out of root into my user account, it doesnt work.

Im still new, and sure its something stupid, but help would be appreciated


Thanks
 
Old 12-15-2009, 03:38 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
What happens if you back-ground the process? It still terminates when
you log out? Have you considered starting it from rc.local rather than
manually?


Cheers,
Tink
 
Old 12-15-2009, 04:56 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,400

Rep: Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395
You'd have to nohup it to stop it terminating on logout. Backgrounded (&) tasks are still connected to the initiating terminal session.

nohup prog &
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
transmission permission trouble goncalopp Linux - Software 2 04-10-2009 09:23 AM
Transmission CVS or 0.7 assasukasse Debian 0 10-09-2007 12:21 PM
How to Get The 'transmission (10)' Value using snmpwalk Chiranjib Pal Linux - Server 0 08-14-2007 12:53 AM
How to Get The 'transmission (10)' Value using snmpwalk fiem Linux - Networking 0 08-08-2007 10:26 AM
mode of transmission cybercop12us Linux - Networking 1 11-28-2001 07:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration