-   Linux - Newbie (
-   -   Toshiba Satellite C655D-S5210 freezes under Kubuntu and Linux Mint (

santner 07-19-2011 10:42 PM

Toshiba Satellite C655D-S5210 freezes under Kubuntu and Linux Mint
I recently purchased this laptop and I've setup Kubuntu and Linux Mint on top of Windows 7. Everything runs well out of the box except that the system occasionally freezes and the only option is to hold down the power button and reboot. The question that I have is where could I look to begin to identify the problem? Which log files would record a potential driver issue that would be causing this freezing?

camorri 07-20-2011 08:04 AM

Is this freezing on all three OS's or just one?

If its all three, or just the linux systems ( both ) then I would look at hardware. Memory can cause this type of unexplained lock up. There is a stand alone test for memory, I think its called memtest.

If it is only one OS, then it is more likely a config problem. System logs, and dmesg are places to start looking.

santner 07-20-2011 10:33 AM

It's only on the linux systems. After freezing and rebooting I checked syslog and didn't see anything around that time to indicate an error. Maybe this indicates a hardware issue since the software didn't have a chance to log it? Or maybe there is a better place to look than syslog?

camorri 07-20-2011 10:43 AM

Run memtest for several cycles. Linux does a much better job at detecting memory problems that windbloze. Some install CD's and DVD's offer it as an option before you install. You can boot a live CD and test memory.

cheerupcharlie 07-20-2011 12:56 PM

I'm a long-time LQ reader - but actually registered an account just to contribute to this thread!

I recently (less than a week) ago acquired the very same model Toshiba C655D-S5210. Ever since I have been dealing with problem after problem installing a linux distro. To aid in troubleshooting or prevent you from making the same mistakes, here's some entries from the log I've been keeping:

There have been three types of crashes so far:
1) System Freeze Crash. Completely frozen, no access via SSH, no mouse, frozen video. Only recourse is to hard-reset
2) Video Fuzzy Crash. Video suddenly goes fuzzy as if the horizontal hold knob got stuck. No SSH. Only recourse is to hard-reset
3) Reboot Crash. Systems just reboots. Has happened on other machines when application goes seriously haywire. This has been the least common crash on this unit.

Under Ubuntu and it's derivatives I've sometimes noticed entries like this in the syslog: (XX = various numbers)

... kernel: Do you have a strange power saving mode enabled?
... kernel: Uhhuh. NMI received for unknown reason XX on CPU 0.
... kernel: Dazed and confused, but trying to continue
... kernel: Do you have a strange power saving mode enabled?
... kernel: Uhhuh. NMI received for unknown reason XX on CPU 0.
... kernel: Dazed and confused, but trying to continue
... kernel: Do you have a strange power saving mode enabled?

After researching that problem I tried adding boot variables via grub/grub2

Some options have included:

acpi=off - most stable but no networking at all (no wired or wireless)
nohpet - seemingly no effect good or bad
acpi=copy_dsdt - a known fix for Toshiba units, but it shouldn't be required on newer kernels. No change to my problems.
nmi_watchdog=0 - no effect good or bad (I still got the occasional NMI error in the syslog as above)

I checked Toshiba's web site and downloaded and applied the most recent BIOS update (1.60)

Over the last five days I've tried numerous distributions, including:
PCLinuxOS Phoenix (most stable so far. occasional "Fuzzy Video Crash")
Debian 6.01 Squeeze (no wireless, random Fuzzy Video crash)
Ubuntu 11.04 (System Freeze and Fuzzy Video crashes while playing video)
Mint 11 (System Freeze and Fuzzy Video crashes while playing video)
Crunchbang 10 (Fuzzy Video crash while doing apt-get update)
Ubuntu 10.04.2 LTS (No network interface at all, wired or wireless. I think I can modprobe the driver, but I have no internet access without the network)
Pinguy OS 10.04 (same as Ubuntu 10.04.2 - early kernels don't see the network hardware)

So here's my summary: early kernels (Ubuntu 10.04 and similar) don't see the network hardware. I haven't had any crashes with those distros, but I hadn't really had much uptime with them either. Early kernels also require the acpi=copy_dsdt line to be applied in GRUB. It's a known issue. Later kernels either crap out after logging NMI errors or just "fuzz out" and need to be powered off.

I've tried using the built-in video drivers with/without compiz and the proprietary video drivers with/without compiz.

Over the last days or so, my log has gotten a little muddled so I can't promise that I've tried every combination of the above of every distro. I'm almost ready to give up and wait for the next kernel release to see if anything gets better.

Sad as it it, I'm glad to hear someone else having problems. While I'll admit that it just might very possibly be faulty hardware - there seems to be much evidence to the contrary with other (similar model) Toshibas. This is the first I've heard of someone else having a similar problem with the same unit.

Sorry to ramble on.

Hope this helps/helped somebody.

I'll be watching this thread.

P.S. I wanted to update this post and mention that I just closed a full 2 hour 30 minute session under PCLinuxOS with no crashes of any kind. The only thing I know is different than usual is that I turned compiz off. Maybe it's a video problem (or also a video problem)? No real proof, I know, but it's the longest I've worked on the machine since I've owned it without a crash of some sort.

camorri 07-20-2011 02:55 PM


Thank-you for your post. Compiz can cause a lot of problems. What video hardware do you have?

This is looking much more like a hardware issue for Toshiba.

cheerupcharlie 07-20-2011 04:39 PM


I agree that this seems like a Toshiba issue. The one nice thing about this is that it's a work laptop (so I didn't pay for it - or choose it) that doesn't have anything important on it yet (hence the linux install-fest). I'm determined to get linux working on it.

lspci lists the interesting tibits as such:

00:01.0 VGA compatible controller: ATI Technologies Inc Device 9802

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

06:00.0 Ethernet controller: Atheros Communications AR8152 v1.1 Fast Ethernet (rev c1)

... and the kernel I'm working on now (the PCLinuxOS distro) is:

Again... so far, so good. This machine, with compiz turned off, had been stable so far. Networking worked out-of-the-box and no video problems since compiz has been off.

Now, I'm wondering if I tried turning compiz off on a previous distro. I got so caught up in grub options and native video vs proprietary video, I don't know if I tested that well enough.

I'm kinda having a hard time getting used to PCLinuxOS. I wanna go to Debian/Ubuntu :(

cheerupcharlie 07-20-2011 07:08 PM

Well... Stability be damned, I removed PCLinuxOS and installed Linux Mint 11 on the Toshiba C655D-S5210. Suspecting that compiz was my culprit, I went through the install and upon first boot I disabled compiz (or so I thought).

Next I opened a terminal window and ran apt-get update && apt-get dist-upgrade. The response was just over 200M of updates, so I sat back and started watching TV. Every so often I would reach over and nudge the touchpad to make sure she didn't freeze up.

About 10 minutes in - she froze. No indication other than total unresponsiveness. So I hard-restarted and went right for the logs. This time I found something! In the kern.log was this entry:


Jul 20 18:45:36 ccso-shcrh kernel: [ 1204.168820] compiz[1571]: segfault at 16 ip 00730d99 sp bfad5800 error 4 in[6f2000+d5000]
I got so excited to have a starting place to begin looking that I came here first.

So there ya go... If I can figure anything out, I'll be sure to report it here. Has anybody else heard of such a thing? And what do I have to do to de-activate compiz? (I uninstalled it before continuing my updates ... that'll stop it!)

camorri 07-21-2011 06:31 AM

Well, another option is to try Slackware 13.37. Compiz is not installed by default. You have to go out of your way to install it on Slack.

PClinxOS is a Mandriva derivative. I was a long time Mandriva user, Compiz was not enabled by default. I'm now using Mageia 1 as backup to Slackware. Mageia is a Mandriva fork, as is very Mandriva like. So far I have found it stable, and like Mandriva, compiz is not enabled by default. So, there are options.

Did you have the ATI proprietary driver installed? Or were you using the Neaveau driver? Just curious...

santner 07-21-2011 08:27 AM

Just for completeness I did run memtest last night and everything came back fine.

The only other piece of information that I can add is that I had this same issue during installation. I'm guessing that when installing linux compiz is not enabled. This happened during a livecd install (run linux off the live cd and install). I'm fairly certain that it also happened during a regular install (F12->Boot from CD/DVD->Install from CD). It's been a week now though and I can't be for sure.

cheerupcharlie 07-21-2011 10:56 AM

The saga continues...

Still on Linux Mint 11, I'm currently going on almost 3 hours of crash-free stability.

While I'm not ready to declare this solved - I think I'm getting closer to proving that the problem is the video driver.

2011-07-21 10:30 After several system and fuzzy video freezes this morning I booted into recovery mode and removed the fglrx driver and installed the latest proprietary ATI Catalyst™ Proprietary Display Driver (executable binary, version 11.6 dated 2011-06-15). So far I’ve had one hour and 50 minutes of crash-free uptime. If this is the magic formula here’s the details:
OS: Linux Mint 11
Kernel: 2.6.38-10-generic
Video Driver: ATI Catalyst Driver v 11.6
No Compiz

2011-07-21 11:00 Reinstalled/activated compiz. Stayed away from the Cube plugin per Mint 11 release notes

2011-07-21 11:30 Just over 2:30 of crash-free up-time with new video driver. Found a paragraph on Wikipedia which acknowledges problems with fglrx and linux

2011-07-21 11:50 CRASH! System froze up as I was writing this. Damn. I rebooted and disabled compiz again. I still think this is a video problem. I'm getting closer...

More news as events warrant. :)

santner 08-03-2011 09:25 AM

VMware Player
I've been using VMware player with Ubuntu 11.4 for a few days now without any issues. It's a bit painful, but until I can find a clean solution it is what it is.

PhysicsMark 08-05-2011 09:44 PM

Same Boat...
I'm in the same boat as you guys: I just bought the c665-s5210 Satellite and am having all sorts of trouble getting Ubuntu 11.04 to run stably on it. Invariably, after a few minutes after booting the screen will go fuzzy and shake and I have to hard boot. Sometimes before the crash, I also have difficulty in maintaining an ethernet or wireless connection. I'd love to help troubleshoot and resolve this issue if I can.

verzonnen 08-23-2011 02:09 PM

I bought this toshiba laptop because it is a low power and I just surf the internet.

When I use the network it freezes, more so on the wired connection then on the wireless connection. The network connection on the wireless gets very slow before the system finally freezes. I am running kubuntu 110.04 32 bit and upgraded the kernel to 2.6.38-11-generic

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
06:00.0 Ethernet controller: Atheros Communications AR8152 v1.1 Fast Ethernet (rev c1)

No idea if network is the (only) problem or not but without me actively using the network my uptime seems to be much higher, been up half an hour now, while the kernel update crashed my system three times.

Looking around in other places seems to indicate this freezing is a common problem with toshiba laptops and I wish I had done my homework and bought another laptop. If any one knows of a fix I would be really happy.

santner 10-14-2011 07:43 AM

Has anyone tried the latest version of Ubuntu yet?

All times are GMT -5. The time now is 09:36 AM.