-   Linux - Newbie (
-   -   Toshiba boot problems - USB ext HDD - new install (

wtriver 10-29-2003 12:41 PM

Toshiba boot problems - USB ext HDD - new install
My friend has a Toshiba Satellit Pro M15-S405 - Here's the issue, and I can't find a way around it.. HELP!!! :)

He has a USB external Hard Drive, on which he wanted to install SuSe 8.2

So.. he did just that. Here the problem arises. The laptop comes with WinXP on it (not sure if this is the issue or not) and once he installed SuSe8.2 (it saw and installed onto his USB drive without a hitch) it apparantly trashed the MBR??

Whenever he tries to boot normally, he gets the following message:
LIL00000000000000000000 ("something like that")

And neither GRUB or LILO will work. I had him re-run the install and try Lilo rather than GRUB.. same thing.. it won't boot past the error message. - basically, we've got no bootloader.

Now then, for S&G if he boots via the SuSe 8.2 CD 1, it will say that linux is already installed and of course gives you the option to go ahead and boot it. Works flawlessly... SuSe boots on into the GUI and everything... aside from the softmodem everything has been auto-detected, works like a charm. The windows partition is still intact and can be mounted and accessed, we just can't get to it at boot time to boot it anymore.

SOOOOoooo.. can anyone explain to me what the trouble is with the MBR / boot loader, and what I could do to fix this for him? I'm stumped. (Albeit I am rather low on the knowledge totem-pole for linux. Been running 7.3 then 8.0 for years now, love it, but still not that well versed)

Thanks all and take care,

randomblast 10-29-2003 12:59 PM

yes, the MBR is only 512 bytes, which only stores the stage1 image of the bootloader, which is looking for the stage2 image in /boot on the USB hard drive, which LILO/GRUB cannot see (to the best of my knowledge).
the best way to fix it is:-

step 1 - use the recovery console on the winxp disc to reinstall the windoze bootloader (google it)

step 2 - use loadlin to boot linux (dunno if u can do this in winxp)

that's not really very helpful though, because there are a lot of "if"s

another way would be to repartition with partitionmagic or similar with an 8MB ext2/ext3 partition, with the rest as an NTFS partition for XP.
then re-install SuSE with the 8MB partition mounted as /boot, and a single ext2/ext3 partition on the USB hard drive mounted as /

wtriver 10-29-2003 02:42 PM

Ok, I'll give the windoze mbr restore a try first and then go from there... basically the machine won't boot into winxp for PM to work from, unless PM is bootable from CD or otherwise now? (I haven't used Partition Magic in at least 2 years, and that was dealing with OS/2 & windoze, PM being run from the later)

Hopefully the MBR restore will go well, we can get into XP and go from there. He's a college student and so he's a hurting unit for his docs, etc. I've got him reformatting in Open Office for now, but I'll hop over tonight and see where we land.

Thanks a mil.

randomblast 10-30-2003 01:54 PM

i've never actually used PM, but apparently it is bootable from cd and it resizes partitions without damaging data.
i think you should just leave 8MB or so free and boot from the suse cd and repartition with that.
i would start with reinstalling the windoze botloader though, so you at least have windoze to work with.

wtriver 11-01-2003 05:48 PM

Thanks RB, The WinMX fixmbr worked just fine. Loadlin won't work unfortunately, but we just made him a boot disk, so he can just throw that in anytime he wants to boot into linux. Over time he's going to get all his docs and everything reformatted over to Open Office, and he's using Open Office for all his new projects... he's really excited and liking SuSe 8.2 ... gotta get his modem working though. I've found a couple of drivers on the web for that softmodem. Gonna see if they'll work.

Take care, and thanks for the info.

randomblast 11-02-2003 05:38 PM

coolio, just been having a windoze vs. linux debate with a couple of mates, i think i lost :(

All times are GMT -5. The time now is 05:25 PM.