LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   TortoiseSVN Commits but Files not Uploaded to Fedora SVN Server Repo (https://www.linuxquestions.org/questions/linux-newbie-8/tortoisesvn-commits-but-files-not-uploaded-to-fedora-svn-server-repo-4175605334/)

rachaelw 05-05-2017 03:04 PM

TortoiseSVN Commits but Files not Uploaded to Fedora SVN Server Repo
 
I setup a SVN repo on my Fedora 25 Server, and I connect to it using svn+ssh authenticating with a private key and no password. I am able to work with the repository correctly from my Ubuntu client, but I am not able to get it working correctly with my Windows 10 client running TortoiseSVN. TortoiseSVN is able to see and access the repository correctly (using puTTY to authenticate the ssh connection), however, after the checkout/add/commit process in tortoiseSVN the files committed to the repository are not uploaded to the server. TortoiseSVN shows a new revision number for the repository, but when I look at the server the revision number has not changed.

My best guess is that it is a permissions issue in the SVN repository configuration file in /home/svn/occo_svn_repo/conf/svnserve.conf
I uncommented the following lines in the conf file:
Code:

anon-access = read
auth-access = write
realm = My First Repository

That didn't work, so I tried temporarily changing anon-access to write to see if I could troubleshoot whether it is a permissions issue. It didn't fix the problem, so I changed it back to the above. I also tried starting an entirely new repository, but I had the same issue. I read the relevant chapters of the SVN and TortoiseSVN manuals, but I still feel like an idiot.

Has anyone run into this problem or have any idea why it might be happening?

Habitual 05-06-2017 05:12 PM

First thought is Firewall, or other restriction.
I put my users in conf/passwd manually.
I wouldn't mess with conf/svnserve.conf as that's for the service, not access.

Sorry, wish I had more.


All times are GMT -5. The time now is 06:39 AM.