-   Linux - Newbie (
-   -   /tmp directory is full? (

Moses420ca 08-06-2004 01:10 PM

/tmp directory is full?
I'm using Mandrake 10.0 installed on a single disk with 2 partitions. A half gig swap and a 12 GB root.
Whenever I try to copy anything to the /tmp directory of any size like when I use KaudioCreator to rip a cd, I get an error message "Disk full". The disk has 9 GB free.

Thanks for any help.

david_ross 08-06-2004 01:45 PM

What does the output of this show:
df -h

Moses420ca 08-08-2004 07:32 AM

I've since moved to slackware and I'm using the same partitions made by mandrake. I have not tried to rip a cd yet but that command returns. 1 partition named /dev/hda5 of 13 GB. 2.2GB used, 11GB Free mounted on /.

It would have said about the same while using Mandrake.

That command is much faster then du though. Thanks.

trickykid 08-08-2004 09:32 AM

When your ripping this cd, what are your configurations when ripping? Like have you set it to a limit in size... cause something it sounds from that program is using up all available space but when it errors out probably removes whatever is taking up space cause it can't finish the rip, etc.

Next time your ripping, run the df -h or try doing a:

du -h /tmp | sort -n

And it will list all the files and such and you can see which one is taking up the most space, etc.

eightysixme 01-20-2005 01:18 AM

kaudiocreator rip error: /tmp full, cannot write to /tmp
i can't rip my audio to the /tmp folder, and output of df -h:

# df -h
Filesystem Size Used Avail Use% Mounted on
33G 7.1G 25G 23% /
14G 1.2G 13G 9% /home/chris/mnt/f
19G 33M 19G 1% /home/chris/mnt/jigen
7.7G 33M 7.7G 1% /home/chris/mnt/lupin
21G 14G 6.8G 67% /home/chris/mnt/pax
9.8G 3.0G 6.9G 31% /home/chris/mnt/w
none 188M 328K 188M 1% /tmp

the last item, the /tmp, shows only 188M available. how do i increase the available space for /tmp? thanks, i know someone can tell me..! i hope. *MSN Messenger account

tormented_one 01-20-2005 01:28 AM

I don't know how to change the size of /tmp. But how a bout making a directory in /var instead of /tmp? You could just del when done.

eightysixme 01-20-2005 01:34 AM

tmp folder in /var, as expansion
i'd rather not do this, considering a very cluttered file-tree, already! it's a good idea, to just symlink (ln -s), but isn't there a way to change the reported available space, for the current /tmp folder in the root partition?

jschiwal 01-20-2005 01:47 AM

Actually, there is a /var/tmp directory already that you could use. The /tmp directory is really for the system. Users should use /var/tmp.

eightysixme 01-20-2005 01:59 AM

yielding on the matter
okay, so since i've gotten so much reply regarding using /var/tmp, instead, i:

# ln -s /var/tmp/systmp_xtra /tmp

is this all i have to do, then? (please read prior posts in the thread)

tormented_one 01-20-2005 02:03 AM

you may wanna mkdir in /tmp to something like /tmp/cdrip. not just /tmp cause everything that goes to /tmp would go to /var/tmp.

eightysixme 01-20-2005 02:16 AM

more kaudiocreator hell..
hmm.. i still get:

"Could not write file /tmp/kde-chris/kaudiocreatorJwjZMb.tmp Disk full."

I'm very interrested in just making the os show more available space, in the folder. i found a link to what i'm talking about, but i'm scared to do it, considering the file it references, is not present:

jschiwal 01-20-2005 06:35 PM

Don't make a link from /tmp to /var/tmp. Use /var/tmp in the program setup, such as k3b's setup. Some people have a ~/tmp directory that they use instead. The /home partition usually is quite large, plus a user has full access rights to ~/tmp/ as well. Another reason may be for privacy.

eightysixme 01-21-2005 03:53 PM

kaudiocreator setup
in the setup for kaudiocreator, there is only one user-defined save path--the one for the encoded rips. this folder isn't even touched: before the application encodes them, it first saves them in /tmp. the output of df -h shows the /tmp folder is allowing 188mb of space, whereas the parent, root, shows far more space. i tried the /etc/vfstab file entry, from my previous post, rebooted, and the o.s. still reported the 188mb available. i've since deleted the /etc/vfstab file i created, citing no change. i even tried making a new /tmp, but this only affirmed that there is a file elsewhere, dictating the reported availability within /tmp. i really don't want to link to another location. i want the single /tmp folder, and an unlimited allocation. though maybe my frustration stems from incorrectly creating the link to my alternate temporary folder. who knows!?

as you see it, and confused,

Chris Rion

eightysixme 01-21-2005 07:48 PM

Why It's Called, "Linux Newbie"
well, as a typically straightforward and illuminating solution, i decided to use a spare unmounted partition as my mount for /tmp. the o.s. asked me if i wanted to move the contents of the current /tmp folder, into it; to which i chose 'yes'. just to be sure, i restarted--everything went well! also, i verified the available space:

# df -h
Filesystem Size Used Avail Use% Mounted on
33G 7.1G 25G 23% /
14G 1.2G 13G 9% /home/chris/mnt/f
19G 295M 19G 2% /home/chris/mnt/jigen
21G 14G 6.3G 69% /home/chris/mnt/pax
9.8G 2.9G 7.0G 30% /home/chris/mnt/w
7.7G 293M 7.0G 4% /tmp

aah! sweet satisfaction.. now, kaudiocreator is churning away. i'm very happy! this lends stock to the saying about learning more from mistakes, than success, eh? inspiration for this, came from another post @ gods bless this forum!

till next time..

Chris Rion

All times are GMT -5. The time now is 11:38 AM.