LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-05-2003, 12:14 PM   #1
CYRUSS612
LQ Newbie
 
Registered: Oct 2002
Location: chicago
Posts: 15

Rep: Reputation: 0
Time in redhat 7


Hey everyone I just have hopefully one stupid question. I am running redhat 7 as my mailserver here at work. The problem I am having is the time when I go into startx and into kde the clock on the bar is always 45 minutes fast . My question is how can I change the system time as I have found out it as not as easy as a win 2000 server to do the same. I really appreciate all of your help , ya know I do have one more question is there any way I can get the kde of linux not to be so big . When I leave Root and type in startx and go into kde the screen seems to be huge . I will try and explain it better. All the icons seem to be the same size but the desktop is what seems to be huge . If i want to get to the kde bar i have to set my mouse arrow down in order to get to it , it is almost like it scrolls to get there . Please help i know it has somthing to do with the resolution but I would really like this fixed. Thanks in advance for all of your help.
 
Old 02-06-2003, 10:11 AM   #2
CYRUSS612
LQ Newbie
 
Registered: Oct 2002
Location: chicago
Posts: 15

Original Poster
Rep: Reputation: 0
None of you great linux gurus no the answers to my problems
 
Old 02-06-2003, 11:48 AM   #3
jason
LQ Newbie
 
Registered: Jun 2002
Location: Baltimore, MD
Distribution: Red Hat 7.2
Posts: 10

Rep: Reputation: 0
Teach a person to fish

Google is your friend. A search on 'linux set date time' turns up a number of results. The first reads thusly:

To set the system clock under Linux, use the date command. As an example, to set the current time and date to July 31, 11:16pm, type ``date 07312316'' (note that the time is given in 24 hour notation). If you wanted to change the year as well, you could type ``date 073123161998''. To set the seconds as well, type ``date 07312316.30'' or ``date 073123161998.30''. To see what Linux thinks the current local time is, run date with no arguments.

(http://www.linuxsa.org.au/tips/time.html)

If you really want to do this with a GUI, Google will probably help with that, too.
 
Old 02-06-2003, 10:11 PM   #4
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Re: Teach a person to fish

Quote:
Originally posted by jason
Google is your friend. A search on 'linux set date time' turns up a number of results. The first reads thusly:

To set the system clock under Linux, use the date command. As an example, to set the current time and date to July 31, 11:16pm, type ``date 07312316'' (note that the time is given in 24 hour notation). If you wanted to change the year as well, you could type ``date 073123161998''. To set the seconds as well, type ``date 07312316.30'' or ``date 073123161998.30''. To see what Linux thinks the current local time is, run date with no arguments.

(http://www.linuxsa.org.au/tips/time.html)

If you really want to do this with a GUI, Google will probably help with that, too.
Damn good answer Jason.
 
Old 02-06-2003, 11:15 PM   #5
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,137

Rep: Reputation: 65
Re: Time in redhat 7

Quote:
Originally posted by CYRUSS612
Hey everyone I just have hopefully one stupid question. I am running redhat 7 as my mailserver here at work. The problem I am having is the time when I go into startx and into kde the clock on the bar is always 45 minutes fast . My question is how can I change the system time as I have found out it as not as easy as a win 2000 server to do the same. I really appreciate all of your help
Look at the man page for `date' and, perhaps, `hwclock'. Also, you might want to look into setting up NTP on the system so that it can synchronize the system clock to an accurate time reference. Until I had NTP set up properly (or rather I had the firewall configured to let ntp though), I was setting the date/time by hand and running hwclock to set the hardware clock to the current system time. That way, when I rebooted, the hardware clock wouldn't be so far off (due to clock drift).

Quote:
, ya know I do have one more question is there any way I can get the kde of linux not to be so big . When I leave Root and type in startx and go into kde the screen seems to be huge . I will try and explain it better. All the icons seem to be the same size but the desktop is what seems to be huge . If i want to get to the kde bar i have to set my mouse arrow down in order to get to it , it is almost like it scrolls to get there . Please help i know it has somthing to do with the resolution but I would really like this fixed. Thanks in advance for all of your help.
Aahh... It sounds like your X server was set up to use a window into a larger workspace. I.e., you have, say, a 1024x768 window into a 1800x1600 desktop. I found that to be incredibly annoying and tweaked my X configuration to eliminate it. If memory serves, when I ran `X -configure' there was a question asking whether I wanted a window into a larger workspace and I answered ``N'' to get rid of it. (Anyone else remember where you turn this off -- without manually editing the X config file that is?)

Hope this helps,

Rick
 
Old 02-07-2003, 09:33 AM   #6
CYRUSS612
LQ Newbie
 
Registered: Oct 2002
Location: chicago
Posts: 15

Original Poster
Rep: Reputation: 0
Rick Thank you for your help, I really appreciate you taking the time to help. You know I love when someone says oh well just search on google, dont they think I tried that. I thought it was not that difficult of a question, I thought maybe someone would know a quick fix. Anyway thanks again rick for helping me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
First time using redhat 7.2 ring16master Linux - Newbie 3 11-18-2005 12:35 PM
Redhat 8 time slow chungchungip Red Hat 7 04-12-2005 03:56 PM
about time display in redhat 9 yjiang Linux - General 1 10-27-2004 12:02 AM
Redhat time... randomdave Linux - Newbie 3 10-24-2003 07:19 AM
Redhat 7.2 and system time TNJed Linux - General 2 12-19-2001 10:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration