LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-29-2016, 04:30 PM   #1
pconstantatos
LQ Newbie
 
Registered: Dec 2016
Posts: 29

Rep: Reputation: Disabled
Time differences in dual-boot PC


I am running Linux Mint18.1 and Windows 10 in dual-boot installations on a number of PC's, all of them Dell Optiplex desktops and Dell Latitude laptops. I am geting the same problem on all of them. Although time is on auto (network-provided time) and time zones on all systems to +2 (Athens) whenever I boot Windows after Linux the clock on Windows will be two hours behind. The time in Bios changes as well. The time does not change when I boot consecutive instances of Windows, only when Linux comes into play. I use Linux for 90% of my work, Windows is dedicated only to Photoshop, Lightroom and Media Monkey. Still I cannot do without Windows otherwise I would uninstall them. Any suggestions as to how I can correct the problem?
 
Old 12-29-2016, 04:36 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,246

Rep: Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639
You have a mis-match in timezone handling - Windows has always used localtime, and *nix UTC. I believe with Win10 you can coerce it to change, but easier to run Linux in Athens localtime. Mint should have a howto somewhere, but this might get you started.
 
Old 12-29-2016, 04:48 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 17,831

Rep: Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402
To elaborate a bit the mismatch is due to what linux uses as the timezone for the hardware clock. There is no BIOS setting for timezone. As stated Windows defaults to local time and linux UTC and this causes the time to be off when you switch to the other operating system.

By changing Mint to use localtime for the hardware clock should resolve your issues. Using systemd the way to change the configuration setting is:

sudo timedatectl set-local-rtc 1


The actual configuration file is /etc/adjtime.

Last edited by michaelk; 12-29-2016 at 05:00 PM.
 
Old 12-29-2016, 05:20 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,246

Rep: Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639
Are Mint using systemd these days ?.
 
Old 12-29-2016, 05:25 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 17,831

Rep: Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402
I thought that 18 switched to systemd but I could be wrong...
 
Old 12-29-2016, 06:29 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 7,352

Rep: Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481
change your Linux systems rc.conf file to "localtime"
to set time date in Linux and set the hwclock
Code:
# date -s "1 JAN 2017 00:01:00"
# hwclock -w

Last edited by BW-userx; 12-29-2016 at 06:33 PM.
 
Old 12-30-2016, 06:21 AM   #7
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19 MATE
Posts: 6,421
Blog Entries: 2

Rep: Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107Reputation: 2107
Quote:
Originally Posted by syg00 View Post
Are Mint using systemd these days ?.
Yes. Starting with Linux Mint 18, Mint is based on Ubuntu 16.04 which uses systemd.
 
Old 12-30-2016, 06:31 AM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,246

Rep: Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639
Thanks; hope they did a better job than Debian appeared to have done - seen plenty of issues reported here. Time to go upgrade one of my old Mint systems.
 
Old 12-31-2016, 05:46 PM   #9
pconstantatos
LQ Newbie
 
Registered: Dec 2016
Posts: 29

Original Poster
Rep: Reputation: Disabled
Thank you all and Happy New Year. The problem has been solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dual Boot response time bernie2010 Linux - Newbie 1 11-05-2010 10:23 PM
rhel5 dual boot installation- no grub at boot time. xxx_anuj_xxx Red Hat 5 12-30-2007 03:53 AM
First Time Dual Boot Setup iJScruff Linux - Newbie 12 08-08-2006 10:09 AM
Dual Boot Delay Time = 0 Raggit Linux - General 3 01-26-2005 10:25 AM
dual mice at boot time pete123 Linux - Hardware 2 12-06-2004 03:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration