LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2018, 11:04 AM   #1
globetrotterdk
Member
 
Registered: Nov 2006
Posts: 205

Rep: Reputation: 14
Tilda as floating window with i3wm on MiyoLinux.


I just started the i3wm version of MiyoLinux (Devuan Jessie 64bit) and am trying to get Tilda to become a floating window that can show or hide with F12. Unfortunately, I have little experience with i3wm, but I have tried to look through various documentation and Google. The i3wm version is:
Code:
$ i3 --moreversion 2>&- || i3 --version
Binary i3 version:  4.8 (2014-06-15, branch "4.8") © 2009-2014 Michael Stapelberg and contributors
Running i3 version: 4.8 (2014-06-15, branch "4.8") (pid 2202)

The i3 binary you just called: /usr/bin/i3
The i3 binary you are running: x-window/i3
The command that I am trying to use in the i3wm config file is:
Code:
# Start Tilda
exec tilda -c -p dropdown -T "tilda" for_window [class=”Tilda” instance=”dropdown”] floating enable move absolute position 0 0
I can get tilda to start at boot with
Code:
exec tilda -c
however, when I use the rest of the string, Tilda refuses to start. It is possible to start it manually.

What I would like to within i3wm is to:
Get Tilda to float as a window above all others.
Tilda at full desktop/monitor width and 46 percent height.
 
Old 01-12-2018, 01:46 PM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 12,471
Blog Entries: 9

Rep: Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375
try like this:
Quote:
Originally Posted by globetrotterdk View Post
Code:
# Start Tilda
exec tilda -c -p dropdown -T "tilda" 
# make it floating
for_window [class=”Tilda” instance=”dropdown”] floating enable move absolute position 0 0
 
Old 01-12-2018, 03:28 PM   #3
globetrotterdk
Member
 
Registered: Nov 2006
Posts: 205

Original Poster
Rep: Reputation: 14
Thanks for the quick reply. Nope, it still doesn't start.
 
Old 01-12-2018, 04:06 PM   #4
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,135

Rep: Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927
if I remember right it has a default F1 I think was the command to get it to drop down , just try starting in a different terminal then hitting F1

if that works then just add it to your i3 start up command so it will always be there.

edit

https://github.com/lanoxx/tilda

Last edited by BW-userx; 01-12-2018 at 04:08 PM.
 
Old 01-13-2018, 03:23 AM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 12,471
Blog Entries: 9

Rep: Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375Reputation: 3375
Quote:
Originally Posted by globetrotterdk View Post
Thanks for the quick reply. Nope, it still doesn't start.
that's a very short answer.
c'mon, try a little harder.
did tilda even start properly?
or maybe you got the class/instance wrong?
re-visit that excellent i3 documentation.
 
Old 01-13-2018, 09:57 AM   #6
globetrotterdk
Member
 
Registered: Nov 2006
Posts: 205

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by ondoho View Post
that's a very short answer.
c'mon, try a little harder.
did tilda even start properly?
or maybe you got the class/instance wrong?
re-visit that excellent i3 documentation.
My Internet provider is dicking around with me, so yes I am having to use short answers because I running off my mobile phone data plan. No, I unfortunately have to use my mobile phone, so I don't have the ability at this time to look through all the i3 documentation, regardless of how good it is. Before I tried to get Tilda to float, Tilda was working at boot up, but it would take the whole screen.

Last edited by globetrotterdk; 01-13-2018 at 09:59 AM.
 
Old 01-13-2018, 10:05 AM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,135

Rep: Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927
a line off my old i3 config for auto starting
Code:
# system tray items
exec --no-startup-id volti
i3 docs state this
Quote:
4.17. Automatically starting applications on i3 startup

By using the exec keyword outside a keybinding, you can configure which commands will be performed by i3 on initial startup. exec commands will not run when restarting i3, if you need a command to run also when restarting i3 you should use the exec_always keyword. These commands will be run in order.

See [command_chaining] for details on the special meaning of ; (semicolon) and , (comma): they chain commands together in i3, so you need to use quoted strings (as shown in [exec_quoting]) if they appear in your command.

Syntax:

exec [--no-startup-id] <command>
exec_always [--no-startup-id] <command>
https://i3wm.org/docs/userguide.html..._on_i3_startup
so it's be like this
Code:
exec --no-startup-id tilda
F1 is the default drop down / up command and on first run it opens a conf setting gui
 
Old 01-13-2018, 10:58 AM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,135

Rep: Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927Reputation: 1927
haha I found another i3 config file I have using tilda
Code:
# Dropdown Terminal set to postion and floating mode
bindsym $sup+t exec --no-startup-id tilda 
for_window [class="Tilda"] floating enable
 
  


Reply

Tags
devuan, i3, window


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] SlackBuild Tilda j9x.inca Slackware 5 08-13-2012 01:21 PM
Tilda causes hang in startup hilegunslinger Linux - Newbie 3 06-06-2007 12:46 AM
how to install tilda cad Linux - Software 1 02-08-2007 03:33 AM
Missing tilda character on keyboard farpoint Debian 8 07-11-2005 05:50 PM
How do I reattach floating window to its parent? bscbrit Linux - Newbie 3 09-24-2003 10:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration