LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Thunderbird won't launch - Fedora 15 (https://www.linuxquestions.org/questions/linux-newbie-8/thunderbird-wont-launch-fedora-15-a-908626/)

VicRic 10-17-2011 12:45 PM

Thunderbird won't launch - Fedora 15
 
Hi

I'm using Fedora 15 and I was using Thunderbird without a problem until today. Now when I click on the TB icon it attempts to launch -shows the "working" circle thing running, but after 3 or 4 secs it fails.

Questions:

1) because I'm using the graphical interface I don't get any error message or error log which is very disconcerting - do you know where I can find the error report or log for Thunderbird?

2) when I try to launch TB from Terminal I get this:

[victor@FEDORA ~]$ thunderbird
/usr/lib/thunderbird/thunderbird-bin: /usr/lib/xulrunner-2/libnss3.so: version `NSS_3.12.10' not found (required by /usr/lib/thunderbird/libxul.so)


Is this the proper way to launch TB from Terminal?

BRgds
V.A.

macemoneta 10-17-2011 01:38 PM

How did you install thunderbird? If you installed it manually, you need to remove it and then:
Code:

yum install thunderbird
to get and maintain the proper requisites. If you want to keep the manually installed version, just run:
Code:

yum install nss

frankbell 10-17-2011 07:01 PM

If you open a terminal and start Thunderbird from command line, that should produce some useful error messages.

VicRic 10-18-2011 03:56 AM

Apparently it's complaining about /usr/lib/xulrunner-2/libnss3.so not being the correct version (?)

[victor@FEDORA ~]$ su
Password:
[root@FEDORA victor]# thunderbird
/usr/lib/thunderbird/thunderbird-bin: /usr/lib/xulrunner-2/libnss3.so: version `NSS_3.12.10' not found (required by /usr/lib/thunderbird/libxul.so)


so I go and try to update Thunderbird version, but it is already up to date

[root@FEDORA victor]# yum install thunderbird
Loaded plugins: presto, refresh-packagekit
google-chrome | 951 B 00:00
rpmfusion-free-updates | 2.7 kB 00:00
rpmfusion-nonfree-updates | 2.7 kB 00:00
updates/metalink | 15 kB 00:00
Setting up Install Process
Package thunderbird-7.0-1.fc15.i686 already installed and latest version
Nothing to do


I go and try to update NSS version, but it is already up to date

[root@FEDORA victor]# yum install nss
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Package nss-3.12.10-6.fc15.i686 already installed and latest version
Nothing to do



I hope there is something to do

thezerodragon 10-18-2011 08:41 AM

VicRic,

Silly question: are you running 32 or 64-bit Fedora?

VicRic 10-19-2011 04:54 AM

ZeroDragon, as far as I know I'm running 32bit version but I'm not that sure - do you know a command that will tell me that for sure?

VicRic 10-19-2011 04:56 AM

I'm also posting this question at the Fedora Forum. From that conversation, this is the latest post:

Mr Ferris, thanks.

I gathered this information but please don't follow my suggestions because I'm new to Linux and I don't really know what I'm doing.

Anyway, here it is - to recap:

[root@FEDORA victor]# thunderbird
/usr/lib/thunderbird/thunderbird-bin: /usr/lib/xulrunner-2/libnss3.so: version `NSS_3.12.10' not found (required by /usr/lib/thunderbird/libxul.so)

[root@FEDORA victor]# ls -l /usr/lib/xulrunner-2/libnss3.so
-rwxr-xr-x. 1 root root 868136 Mar 22 2011 /usr/lib/xulrunner-2/libnss3.so


[root@FEDORA victor]# rpm -ql nss
/etc/pki/nssdb
/etc/pki/nssdb/cert8.db
/etc/pki/nssdb/key3.db
/etc/pki/nssdb/secmod.db
/usr/lib/libnss3.so
/usr/lib/libnssckbi.so
/usr/lib/libnsspem.so
/usr/lib/libsmime3.so
/usr/lib/libssl3.so


[root@FEDORA victor]# ls /usr/lib/libnss3.so -l
-rwxr-xr-x. 1 root root 1317672 Sep 6 14:00 /usr/lib/libnss3.so


Why are there 2 libnss3.so files? Is that normal?
Maybe it is normal - as I said, I'm new to Linux.

BRds
V.A.

macemoneta 10-19-2011 06:14 AM

It looks like nss is installed in /usr/lib, which is where it belongs. However, Thunderbird is looking for it in /usr/lib/xulrunner-2. That means that your Thunderbird / Firefox / xulrunner installation is mismatched. I suggest you:
Code:

yum clean all
yum reinstall thunderbird firefox xulrunner
yum update


thezerodragon 10-19-2011 08:15 PM

VicRic,

Code:

arch
is the command you were asking for. I was asking because it shows you have the i686 versions, which I believe to be correct for a lot of 32 bit architectures, but not for 64-bit.

VicRic 10-20-2011 04:04 AM

3 Attachment(s)
Thanks, guys

I noticed I don't have currently Firefox installed, probably I uninstalled some time ago as I now use Chrome. So I tried to install it and the system asked me to install also XUL Runtime

Firefox

During the process of installation the system came back with this conflict error message

conflict

I noticed there are old versions of the XUL Runtime installed in the system; I couldn't install the latest one - I got conflicts again.

XULrunner

I can't surpass the conflict. HELP!

unSpawn 10-20-2011 06:21 AM

You've been mixing repos without realizing the consequences. Your prob is with an old F13 Remi Colette version of xulrunner (and applications depending on it) vs the stock F15 one you should use unless you have compelling reasons to not do so. If you want to know which applications will be hit by the update run 'sudo yum -n update libxulrunner 2>&1|tee /tmp/yum.tee' in a terminal window. If you want us to look at it then attach "/tmp/yum.tee" as plain text attachment. If OTOH you don't care which applications will be b0rken by the update try 'yum -y update'. You may have to remove the F13 xulrunner package and applications before proceeding.

VicRic 10-23-2011 12:11 PM

1 Attachment(s)
Thanks for all your comments.

I solved the problem. I simply used the Add/Remove Software program to remove (uninstall) the old version of xulrunner-fc13 and then install the new version xulrunner-fc15.

It looks like this now

afterinstall

I think it was the installation of Eclipse that forced the installation of the old version of xulrunner although I'm not 100% sure. After the uninstall of the old version Eclipse still loads, however I haven't tested it completely to see if anything is broken. I'm not using as of now.

Thanks


All times are GMT -5. The time now is 05:53 AM.