LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2012, 10:52 AM   #1
bcramer
LQ Newbie
 
Registered: Apr 2007
Location: Brazil
Distribution: OpenSUSE
Posts: 16

Rep: Reputation: 0
throttelig disable in OpenSuse 11.1


Hi,
I need to disable throttling in OpenSuse 11.1 to install ATLAS.

How can this be done?

Some background.
In Suse 11.0 it is easily solved with Yast/System/etc/sysconfig Editor then go to System/Powermanagement/Powersave/Scheme/Performance and in Allow_THROTTLING you can define 'yes' or 'no'.

There is no 'Powermanagement' in the System menu in OpenSuse 11.1! Only one net site mentions 'Power-devil' (using the Software manager I see that it is installed)

I could not find a way to use 'Power-devil' to manage throttling.


Thank you
Bruno
 
Old 06-03-2012, 07:33 PM   #2
delis
LQ Newbie
 
Registered: Jun 2012
Posts: 10

Rep: Reputation: Disabled
As far as i know there is no CPU throttling in Opensuse 11.1. But most CPU hardware itself has overheat detection and are doing throttling on their own when a certain temperature is reached.
 
Old 06-03-2012, 07:46 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
this IS Opensuse11.1 ??? right and NOT SELD 11 service pack 1

opensuse 11.1 has been UNSUPPORTED for a long time
it hit EOL on Jan 14 2011 ( OVER a year ago ), please DO NOT use unsupported operating systems .

please stay current only 11.4 and 12.1 are currently supported

see the opensuse wiki page
http://en.opensuse.org/Lifetime

Quote:
There is no 'Powermanagement' in the System menu in OpenSuse 11.1!
there are many MANY things that are not in " menus " is this the suse default KDE4 ? or Gnome2 , or some other DE

now is that the Desktop menues ?
or is this the yast2 menu ?

if this is indeed opensuse11.1 then the repos are dead , there is no installing of the OLD unsupported software


so the normal solutions of actually installing the needed programs are not there
 
Old 06-04-2012, 09:00 AM   #4
bcramer
LQ Newbie
 
Registered: Apr 2007
Location: Brazil
Distribution: OpenSUSE
Posts: 16

Original Poster
Rep: Reputation: 0
Hi,
Thanks for the replies.I solved the problem myself yesterday night.
Here is what I did (without Suse repo support):
First mistake: As I didn't install Suse 11.1 I supposed that all important files were installed.
yast2-power-management is not installed and is not on the OpenSuse 11.1 DVD
However, installing the missing file 'kpowersave' solved the problem.
A 'plug' icon appears at the Desktop lower toolbar and you can manage throttling right clicking on it and set 'performance'. Doing this ATLAS-3.9 installs successfully.

Another way to (probably) doing it is to go to /proc/acpi/processor/... =CPUn (n=o,1,...) and edit the file 'info' for each CPU as follows:
-------------------------------------
Processor id: 0 preserve
acpi id: 1 preserve
bus mastering control: no preserve
power management: yes
throttling control: yes change to 'no'
limit inerface: yes change to 'no'
--------------------------------------
The 'info' file is a read-only file. You will have to change it to a writable file.
I didnīt use this procedure but I suppose it works. More experienced people may give their opinion about this.
 
Old 06-04-2012, 04:15 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
just be warned
11.1 has NOT had any security fixes updates in 1 year +2 months and counting

EVERY known and FIXED issue IS A ISSUE for you

they will NEVER be fixed !!!!

please stay current and install 12.1
or the SOON to be dead 11.4 ( 11.4 hits its end of life this September)
 
1 members found this post helpful.
Old 06-05-2012, 09:48 AM   #6
bcramer
LQ Newbie
 
Registered: Apr 2007
Location: Brazil
Distribution: OpenSUSE
Posts: 16

Original Poster
Rep: Reputation: 0
Hi,
Following the recommendations,I installed OpenSuse 11.4.This version and 11.2 are the only 'new' versions that allow me to run some specific computational chemistry packages.
I'm still not able to find how to disable throttling in this version.Google is not helping. To much theory about throttling but no settings instructions.

I will appreciate if someone can provide the exact procedure for v. 11.4

PS. I opened 'Configure global Power Management Settings', 'Config Power Manager Profiles' ando also Help center: not a word about it.
 
Old 06-05-2012, 09:59 AM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853
Throttling is a security mechanism of the CPU. It is in no way recommended to disable that feature. If you have problems with throttling then you have a hardware problem. Disabling it is nothing more than to cure the symptoms, but not the cause. You should rather check your hardware, especially the CPU's cooling system. It is either not dimensioned properly or not working correctly in that case.
 
Old 06-05-2012, 11:27 AM   #8
bcramer
LQ Newbie
 
Registered: Apr 2007
Location: Brazil
Distribution: OpenSUSE
Posts: 16

Original Poster
Rep: Reputation: 0
Well, lets not loose focus.Like I said in my first post, I have to instal ATLAS. I understand that after installation I can enable it again (although this is not in the UserGuide).
I installed it in my PC with Suse 11.0_x32 and this version has a 'plug icon' in the lower bar (KPowerset in the CPU frequency policy tag with the option 'Performance') which was used to configure to disable throttling which really occurred in each of the four processors.Doing so ATLAS stops complaining about activated throttling and starts to install properly. Otherwise the program would't install.
I need to do this in another PC with Suse 11.4_x64.

The command $> cpufreq-selector -g performance does not work with v. 11.x

The questions remains: How?

Last edited by bcramer; 06-05-2012 at 11:50 AM. Reason: complementary information
 
Old 06-05-2012, 12:19 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853
Quote:
Originally Posted by bcramer View Post
which was used to configure to disable throttling which really occurred in each of the four processors.
Again, this is a hardware problem and disabling throttling can damage your hardware. You have thermal issues if the CPUs are throttling. Nonetheless, if you have those problems and for whatever reason are not willing to fix them it is up to you.
As I can see in the openSuse documentation they mention throttling states, but show no way to change them (may be for the obvious reason that this can damage your hardware). So the only way I currently see to prevent your CPUs from throttling (besides the "fix your cooling system, it doesn't work correctly"-thing) would be to reduce the heat they produce with setting them to the lowest frequency and voltage possible. You can do that either using your BIOS or using CPUfreq to load the power-save governor. Using the performance governor is exactly the thing you should not do to prevent throttling.
 
Old 06-05-2012, 02:14 PM   #10
bcramer
LQ Newbie
 
Registered: Apr 2007
Location: Brazil
Distribution: OpenSUSE
Posts: 16

Original Poster
Rep: Reputation: 0
Ok ,lets abandon the word 'throttling'.

In Suse 11.0 right clicking on the plug icon and selecting in KPowersave menu 'CPU Frequency Policy'
and in 'Set CPU Frequency Policy' you have three choices 'Dynamic', 'Powersave' and "Performance', this last one chosen to solve the ATLAS installation. In doing so nothing bad happened to the PC.

What is the equivalent procedure in OpenSuse v. 11.4_x64?
 
Old 06-05-2012, 02:23 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853Reputation: 4853
OK, I had a look at the install guide for ATLAS and they seem to have no clue what throttling is, they totally mix it up with dynamically clocking the CPU dependent on the load.
So what you want is in fact the performance governor. If that doesn't help then restart the machine, go into the BIOS and disable either Cool'n'Quiet (if you have an AMD CPU) or EIST (Enhanced Intel Speedstep Technology, if you have an Intel CPU).
 
1 members found this post helpful.
Old 06-05-2012, 02:52 PM   #12
bcramer
LQ Newbie
 
Registered: Apr 2007
Location: Brazil
Distribution: OpenSUSE
Posts: 16

Original Poster
Rep: Reputation: 0
YES! This is/was the solution. ATLAS installed very fast!


EIST (Enhanced Intel Speedstep Technology) Intel CPU).

Thank you for you support

mfg
Bruno
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
disable local accounts in windows and opensuse 11.3 kalidoss Linux - Server 1 01-06-2012 07:33 AM
Can't Disable Touchpad Tap-to-Click (Sony Vaio S) (openSUSE 11.4) algorhythm Linux - Laptop and Netbook 7 04-02-2011 09:23 AM
[OpenSUSE 11.1] disable automatic update noir911 SUSE / openSUSE 5 05-09-2009 08:20 AM
How to disable hardware on OpenSUSE 11.0 zinac3f Linux - Laptop and Netbook 1 09-08-2008 04:19 PM
How to disable PREEMPT and/or SMP kernel mode on OpenSuse 10.2 Maladjez Linux - Kernel 3 02-06-2007 02:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration