LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-29-2005, 09:20 PM   #1
ChuckBales
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 0
ThinkPad keyboard


I just installed Ubuntu on my T42 and working through beginners problems. One thing thats been annoying me is when using XP, I have a button on my keyboard that navigates Back and Forward in web browsers. I cant figure out how to get these buttons to do the same in Linux, right now they dont do anything.

Also, I have a set of buttons, one for left click, right click, and when the middle button is held down and I move the trackpoint, it acts as a scroll wheel. However, the middle scroll wheel currently doesnt do anything, any way to enable this?

Last edited by ChuckBales; 12-29-2005 at 09:28 PM.
 
Old 12-29-2005, 10:17 PM   #2
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
what browser/s do you use? i have the page fwd/back keys working with this method:

1. create ~/.Xmodmap if you don't have one
2. put the following keycodes in it:
Code:
! Page left
keycode 234 = F19

! Page right
keycode 233 = F20
3. put "xmodmap ~/.Xmodmap" (no quotes) in ~/.xinitrc (or whatever startup file you use)
4. install the moz/ff xpi plugin from here: http://dqd.com/~mayoff/notes/thinkpad/dqdnavkeys/

i've never gotten the keys to work in non-moz browsers, but i don't use those mainly anyway. unless someone else knows how to do it, you might just have to use the alt+ arrow keys for non-moz browsers.
 
Old 12-29-2005, 10:35 PM   #3
ChuckBales
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Original Poster
Rep: Reputation: 0
I am using Firefox so hopefully that will work for me. However, Im extremely new to Linux and didn't really understand where the xmod files would be, or how to know what startup Im using.
 
Old 12-29-2005, 10:42 PM   #4
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
what distro and desktop are you using? do you start X at the console by typing the startx command, or do you boot right into X with some startup manager that asks you to login with name and password?

the ~/ is shorthand for your home directory. so if your user were named tux, ~/.Xmodmap would be the same as /home/tux/.Xmodmap. the dot in front of the filename means it's a hidden file or directory. at the console, you would do ls -a to see the hidden files/dirs.

Last edited by slackhack; 12-29-2005 at 10:43 PM.
 
Old 12-29-2005, 11:39 PM   #5
ChuckBales
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Original Poster
Rep: Reputation: 0
Im using Ubuntu with GNOME, and after some loading I get prompted for my user and password before arriving at the desktop. I enabled View Hidden Files and dont see a .Xmodmap in my home
 
Old 12-30-2005, 12:02 AM   #6
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
the startup file might already point there, so you might just be able to create the .Xmodmap file and restart to see if it works.

to get the scroll to work with the trackpoint, add these two lines to the /etc/X11/xorg.conf file in the mouse section:

Option "EmulateWheel" "true"
Option "EmulateWheelButton" "2"
 
Old 12-30-2005, 12:08 AM   #7
ChuckBales
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Original Poster
Rep: Reputation: 0
I beleive I have to login to superuser to edit that, but when I type su, and then get prompted for my password, i get an Authentication Failed error. Im using the same password I use to log in, and the password works when I try to edit things like network connections.
 
Old 12-30-2005, 10:45 AM   #8
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
doesn't ubuntu use sudo by default? you could try using that with your regular password.
 
Old 12-31-2005, 03:42 PM   #9
ChuckBales
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Original Poster
Rep: Reputation: 0
awesome, the scrolling and back/forward buttons are up and working, thanks slackhack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Major problems with the keyboard! Microsoft keyboard is not compatable?. aweir14150 Mandriva 2 05-26-2006 07:57 AM
USB Keyboard and Mouse problems on Fedora 3 connected through Thinkpad dock mdisano Linux - Laptop and Netbook 6 09-23-2005 11:24 AM
Thinkpad keyboard problem Darkfalz Linux - Laptop and Netbook 3 09-12-2005 11:59 PM
usb keyboard and soundcard conflict (sound set to keyboard?) netsurf Linux - Hardware 2 04-09-2005 08:08 AM
Thinkpad R31 Keyboard and trackpoint ricesteam Linux - Laptop and Netbook 0 01-24-2004 01:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration