LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Thin client (https://www.linuxquestions.org/questions/linux-newbie-8/thin-client-813697/)

SaHbok 06-12-2010 05:45 AM

Thin client
 
Hello there!
I have mostly configured diskless client. I have some strange configuration:
OS host: Windows Server 2008 SP2. Working with DHCP and TFTP.
ОS first virtual machine: Ubuntu 10.04 desktop. Working with NFS.
ОS second virtual machine: Ubuntu 9.04 server. Copied a filesystem for client from there.
Yes, I am doing a thin client for server. Because my server's HDD broken :(
My problem:
After logging in I have a message:
Code:

cannot execute /bin/bash: Permission denied
If you need more information for problem from me, ask me, because I am not very good at linux. And check all, because I can do mistake in any step of configuring.

P.S. Apologise for my "Engrish"...

AlucardZero 06-12-2010 10:34 AM

Filesystem mounted with "noexec"? Binary from a different architecture?

SaHbok 06-12-2010 04:58 PM

All systems work with i386 compatible.
I can start client with root, if in /etc/default/rcS type SULOGIN=yes. Under root I can execute /bin/bash and for example apache2(apache also can be executed at booting), aptitude. But after executing login script and logging in, I get my error.
I have some fs with noexec, but mount options set by default.
My mount table on client:
Code:

tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rootfs on / type rootfs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.28-11-server/volatile type tmpfs (rw,mode=755)
none on /tmp type tmpfs (rw)
none on /var/run type tmpfs (rw)
none on /var/lock type tmpfs (rw)
none on /var/tmp type tmpfs (rw)
securityfs on /sys/kernel/security type securityfs (rw)
tmpfs on /lib/modules/2.6.28-11-server/volatile type tmpfs (rw,mode=0755)

/etc/fstab client:
Code:

proc                        /proc          proc  defaults  0  0
/dev/nfs                    /              nfs  defaults  1  1
none                        /tmp            tmpfs defaults  0  0
none                        /var/run        tmpfs defaults  0  0
none                        /var/lock      tmpfs defaults  0  0
none                        /var/tmp        tmpfs defaults  0  0

/etc/exports on server:
Code:

/srv/nfs *myip*(rw,sync,no_subtree_check,no_root_squash)
If my settings wrong, please, correct me.
Also i can get some logs. Please, say me, what part of log I must post. :)
The same error with executing with /sbin/klogd.

SaHbok 08-14-2010 02:16 PM

Solved. I used dd, but not cp for copying client filesystem. All links repaired.


All times are GMT -5. The time now is 12:51 AM.