LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   The X11 library '-lX11' could not be found. Please use configure options '--x-include (https://www.linuxquestions.org/questions/linux-newbie-8/the-x11-library-lx11-could-not-be-found-please-use-configure-options-x-include-862681/)

rudiao 02-14-2011 06:36 PM

The X11 library '-lX11' could not be found. Please use configure options '--x-include
 
In the process of installing DDD, I get the following error:
The X11 library could not be found. Please use the configure options '--x-includes=DIR' and '--x-libraries=DIR' to specificy the X location.

I did a "yum install libx11-devel". I was told that the right package was installed. Any ideas?

knudfl 02-15-2011 04:23 AM

Welcome to LQ.

Please use ddd-3.3.12 http://ftp.download-by.net/gnu/gnu/ddd/
>> http://ftp.download-by.net/gnu/gnu/d...-3.3.12.tar.gz
> ddd-3.3.12.tar.gz ( Please read './configure --help' ).

1) # yum -y install compat-gcc-34-c++ && exit
2) cd ddd-3.3.12/ && export CC=gcc34 CXX=g++34 && ./configure && make : No errors.



The older versions may expect the '-lX11' = libX11.so in another location.
( And may have other bugs ? )

If you have further questions, please specify your "Linux OS",
like CentOS 5.5, Fedora 14, etc.
Please read http://linuxsilo.net/docs/smart-questions_en.html
And : http://www.linuxquestions.org/linux/...Ask_a_Question

EDIT : Fedora : # yum install ddd
RHEL, CentOS : The same. 'ddd' is in the EPEL repo https://fedoraproject.org/wiki/EPEL
> > https://fedoraproject.org/wiki/EPEL/FAQ#howtouse


All times are GMT -5. The time now is 01:13 AM.