LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   The MySQL adapter "mysql" is not available. (https://www.linuxquestions.org/questions/linux-newbie-8/the-mysql-adapter-mysql-is-not-available-4175431678/)

eyanu 10-11-2012 09:30 AM

The MySQL adapter "mysql" is not available.
 
Hello, i've googled all round to try and solve this problem but 've failed. Mysql is running and some sites on the same server can access mysql DB.
Package php-mysql is installed and latest, and this is what is my http error logs:

Quote:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_mysql.so' - /usr/lib/php/modules/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
Any one with an idea on how to go about it, will really be grateful.

sackboy 10-12-2012 07:40 PM

Is php-pdo available in your distro? If so, try installing it as well.

e.g. if your distro includes yum:
$ sudo yum install php-pdo

eyanu 10-13-2012 03:48 PM

Yes it is installed:
Quote:

Package php-pdo-5.3.17-10.el6.art.x86_64 already installed and latest version
Nothing to do

mmheera 10-13-2012 04:01 PM

From the error it is clear that there is no pdo_mysql module located at /usr/lib/php/modules/.. Please try to locate the location of your "pdo_mysql.so" file if it is already installed and you may copy it to the right location.

Thanks!

eyanu 10-14-2012 10:00 AM

Hey thanks guys for your continued support but i at last figured it out, you can check out my solution on http://devmento.inc.ug/2012/10/14/ph...dulesmysql-so/


All times are GMT -5. The time now is 05:57 PM.