LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   The Fourth and Final Step... Plz Hlp (https://www.linuxquestions.org/questions/linux-newbie-8/the-fourth-and-final-step-plz-hlp-177948/)

kaz4u2dig 05-04-2004 09:52 PM

The Fourth and Final Step... Plz Hlp
 
I finally learned enough to execute the first three steps to installing apache but the final one
($ PREFIX/bin/apachectl start)
I get this message:

[kaz@localhost httpd-2.0.49]$ /home/kaz/apache/bin/apachectl start
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[kaz@localhost httpd-2.0.49]$

Does Anybody Know What This Means?

46&2 05-04-2004 10:07 PM

i had a similar problem when trying to install MySQL. a socket is what allows you to connect to a service (i.e., MySQL, Apache) running on your local machine.

after rtfm'img until the wee hours of the morning, i decided to completely remove the MySQL directory and untar it again. i started from scratch, and then when i tried to connect to MySQL, it worked! don't know whether or not i did things differently, but when i did a ls -a /tmp there was the beautiful little mysql socket in all it's glory.

but before you do anything drastic, try the command as root (i noticed your prompt wasn't su'd). if that doesn't work, start from square one, making sure to run all installation commands as root.

hope this helps.

kaz4u2dig 05-04-2004 10:17 PM

Hey thanks for the reply. That sounds very complicated??? As of now I am reading the Apache2 Bible.... and waiting for anyone else with an easy fix. Or if anyone could offer some simple explanations in layman's terms I would appreciate that.:study: :study: :study:

P.S. How do I su?

kaz4u2dig 05-04-2004 10:25 PM

OK I entered su enter .... then a password... it logged me on as root.

Then I typed the command again and nothing happened...

[kaz@localhost home]$ su
Password:
[root@localhost home]# /home/kaz/apache/bin/apachectl start
[root@localhost home]#

IS THIS ALL I NEED TO DO???????

46&2 05-05-2004 01:22 AM

if it didn't say anything about a collosal apache/system failure, i'd say you've got it nailed. do a ps (process listing) in the shell or if you're in kde or gnome, look at a graphical process listing and see if httpd is anywhere. if it is, congrats! if not, keep on reading :(


All times are GMT -5. The time now is 11:17 PM.