LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   The extension 'zlib' couldn't be found. (https://www.linuxquestions.org/questions/linux-newbie-8/the-extension-zlib-couldnt-be-found-462511/)

tweety1 07-10-2006 01:29 AM

The extension 'zlib' couldn't be found.
 
Dear All,:D

I'm using PHP 5.1.4,MySQL 5.1.9-beta, and apache 2.2.2.Everything is working fine except propel.I have been trying to install creole since last tuesday.

When i tried to install creole with pear
# pear install http://creole.phpdb.org/pear/creole-current.tgz
downloading creole-current.tgz ...
Starting to download creole-current.tgz (78,080 bytes)
..................done: 78,080 bytes

I have the following errors
The extension 'zlib' couldn't be found.
Please make sure your version of PHP was built with 'zlib' support.
:scratch:

My PHP configuration is

'./configure' '--with-mysql=/usr/local/mysql' '--enable-freetype-4bit-antialias-hack' '--with-gd=/usr/' '--with-jpeg-dir=/usr/local/libjpeg' '--with-png-dir=/usr/local/libpng' '--with-tiff-dir=/usr/local/libtiff' '--enable-libxml' '--enable-dom' '--enable-t1lib' '--with-pcre-regex' '--enable-posix' '--enable-session' '--enable-soap' '--enable-sockets' '--enable-debug' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-inline-optimization' '--enable-libgcc' '--enable-maintainer-mode' '--enable-sysvsem' '--enable-shared-pdflib' '--with-system-regex' '--with-tsrm-pthreads' '--with-x' '--with-xsl=/usr/local/libx' '--with-bz2' '--enable-gd-native-tt' '--with-zlib-dir=/usr/local/lib/zlib/' '--wi '--with-zlib' '--enable-yp' '--with-gettext' '--enable-shmop' '--enable-wddx' '--with-xml' '--with-tsrm-pthreads' '--enable-shared' '--enable-debugger' '--enable-fastcgi' '--with-libexpat-dir=/usr/local/include' '--with-libxml-dir=/usr/local/include/libxml2' '--enable-xslt' '--with-xslt-sablot' '--with-iconv-dir=usr/bin/iconv' '--with-gettext' '--with-gdbm' '--with-apxs2=/usr/local/apache2/bin/apxs' '--enable-mbstring' '--with-kerberos' '--with-xsl' '--prefix=/usr/local/php'

Eagerly waiting for your advice
:newbie:

zeitounator 07-12-2006 02:57 AM

In your etc folder, check if you have a php-cli.ini file. If it is there, check that the zlib extension is loaded in there. If this file does not exist, make the same check in php.ini file.


All times are GMT -5. The time now is 04:57 AM.