LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-10-2013, 08:49 PM   #46
Caskla
LQ Newbie
 
Registered: Sep 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled

Here is the input. It seems that (hd2,gpt5) is my boot partition. Would have continued with the instructions, but I was unsure of what to type after the root=/dev/ part.
I figure the initrd.img-3.2.0-51-generic is the initrd.
Attached Thumbnails
Click image for larger version

Name:	IMG_20131010_184048931.jpg
Views:	54
Size:	235.9 KB
ID:	13703  
 
Old 10-10-2013, 09:56 PM   #47
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,875
Blog Entries: 10

Rep: Reputation: Disabled
Yes it (hd2,gpt5) does indeed look like your boot partition.
And the initial ram disk image (3.2.0-51 generic seems like it could be the initrd-

I (think) now like colorpurple21859 said you would type something like:
Code:
linux (hd2,gpt5) /boot/(your kernel 3.2.0-51)
After the kernel in the above in code I'm not sure if root=/dev would come next or if the name of initrd is what should be typed next.

I'm learning and waiting for colorpurple21859's counsel at this point. Never seen this output before.
 
Old 10-10-2013, 10:07 PM   #48
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 309Reputation: 309Reputation: 309Reputation: 309
Set to the correct value, which might be something like this:
Code:
 set prefix=(hd2,gpt5)/EFI/ubuntu
     set root=(hd2,gpt2)
     insmod normal
     normal
not sure if you have to insert the gpt module
 
Old 10-10-2013, 10:50 PM   #49
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,189

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
See if this will pull up a boot menu.
Code:
configfile (hd2,gpt5)/boot/grub/grub.cfg
If it does and allow you to boot, then copy the /boot/grub/grub.cfg to /boot/efi/ubuntu and see if that will give you a boot menu.
 
1 members found this post helpful.
Old 10-10-2013, 10:53 PM   #50
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,189

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Code:
ls (hd2,gpt5)/boot
will allow you to see what kernels are in you boot menu so you can boot directly as posted before if the configfile command doesn't work.
 
Old 10-13-2013, 05:26 PM   #51
Caskla
LQ Newbie
 
Registered: Sep 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
I (think) now like colorpurple21859 said you would type something like:
Quote:
linux (hd2,gpt5) /boot/(your kernel 3.2.0-51)
I am still unsure about what my kernel is. Could it be the vmlinuz-3.2.0-51-generic?

I will get back to you others in a minute. Thank you all for your help.
 
Old 10-13-2013, 05:34 PM   #52
Caskla
LQ Newbie
 
Registered: Sep 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
The
Quote:
configfile (hd2,gpt5)/boot/grub/grub.cfg
command worked. The only issue is, there is no /boot/efi/ubuntu folder. The only things that are in my efi folder is another folder titled EFI and within that is a Boot folder, an elementary folder, and a Microsoft folder.
 
Old 10-13-2013, 08:54 PM   #53
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You may want to read this.
https://help.ubuntu.com/community/UEFI
 
Old 10-13-2013, 09:36 PM   #54
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,189

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
copy your /boot/grub/grub.cfg to either EFI/boot or EFI/elemtary to get your grub menu. I'm not sure which one
 
Old 10-13-2013, 10:03 PM   #55
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,189

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
This helps explain how grub2 works with efi http://www.rodsbooks.com/efi-bootloaders/grub2.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Dual boot windows 8 and elementary without the grub list brunobbn Linux - Newbie 3 09-23-2013 12:38 AM
how recover from gnu grub version 1.97 beta 4 prompt Hidayathulla.M Linux - Newbie 3 05-28-2011 12:57 PM
F11 does not boot up after install - grub prompt arnoversfeld Fedora 3 08-21-2009 04:45 PM
grub drops to grub prompt on boot, but can use commands to find menu... fix? greenmuzz Linux - Software 7 06-07-2009 04:07 AM
suse 10.1 stops at grub prompt in multi boot install after XP and Fedora Core 6 ptbedford Linux - Newbie 2 12-15-2006 11:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration