LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Terminal Konsole not working for users in KDE 3.2 (https://www.linuxquestions.org/questions/linux-newbie-8/terminal-konsole-not-working-for-users-in-kde-3-2-a-150963/)

wallior 02-26-2004 09:15 PM

Terminal Konsole not working for users in KDE 3.2
 
Hello Guys.

When attempting to open the Terminal Konsole in KDE 3.2 (Running Gentoo and 2.6.3 Kernel) it opens the window, but doesn't give me a prompt.

This only occurs when logging in as a user, not as root.

Not sure what I am doing wrong - any suggestions would be great.

Thanks.

HappyTux 02-27-2004 01:52 AM

Sounds like you do not have a .bashrc and .bash_profile in your home directory here are my files from my /etc/skel directory if you do not have such a directory on your install to copy from.
Code:

>$ cat /etc/skel/.bashrc
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If running interactively, then:
if [ "$PS1" ]; then

    # don't put duplicate lines in the history. See bash(1) for more options
    # export HISTCONTROL=ignoredups

    # check the window size after each command and, if necessary,
    # update the values of LINES and COLUMNS.
    #shopt -s checkwinsize

    # enable color support of ls and also add handy aliases
    if [ "$TERM" != "dumb" ]; then
        eval `dircolors -b`
        alias ls='ls --color=auto'
        #alias dir='ls --color=auto --format=vertical'
        #alias vdir='ls --color=auto --format=long'
    fi

    # some more ls aliases
    #alias ll='ls -l'
    #alias la='ls -A'
    #alias l='ls -CF'

    # set a fancy prompt
    PS1='\u@\h:\w\$ '

    # If this is an xterm set the title to user@host:dir
    case $TERM in
    xterm*)
        PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
        ;;
    *)
        ;;
    esac

    # enable programmable completion features (you don't need to enable
    # this, if it's already enabled in /etc/bash.bashrc).
    #if [ -f /etc/bash_completion ]; then
    #  . /etc/bash_completion
    #fi
fi



>$ cat /etc/skel/.bash_profile
# ~/.bash_profile: executed by bash(1) for login shells.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/login.defs
#umask 022

# the rest of this file is commented out.

# include .bashrc if it exists
#if [ -f ~/.bashrc ]; then
#    . ~/.bashrc
#fi

# set PATH so it includes user's private bin if it exists
#if [ -d ~/bin ] ; then
#    PATH=~/bin:"${PATH}"
#fi

# do the same with MANPATH
#if [ -d ~/man ]; then
#    MANPATH=~/man:"${MANPATH}"
#    export MANPATH
#fi

You need to uncomment the section to include the .bashrc in the .bash_profile file that you create in your home for it to work properly.

wallior 03-07-2004 09:52 AM

Thanks for the input, but that wasn't what fixed my issue.

With Gentoo, /dev/pts file system for Unix98 PTYs is required for 2.6 kernels, and that is where my problem was.

Just thought I better come back make sure that an answer was here incase anyone else came looking.

:)

c0p0n 03-12-2004 10:12 PM

thank U man, I have exactly the same problem with the same software (gentoo, 2.6.3).


All times are GMT -5. The time now is 04:45 AM.