-   Linux - Newbie (
-   -   Telnet : Temporary failure in name resolution : Host name lookup failure (

koodoo 08-26-2005 02:06 PM

Telnet : Temporary failure in name resolution : Host name lookup failure

I am connected to the outside world via a proxy server. The I.P. of the proxy server is
I cannot telnet to a remote computer.

Here is what I am doing :


koodoo@knapsacker:~$ export http_proxy=
koodoo@knapsacker:~$ export ftp_proxy=
koodoo@knapsacker:~$ telnet
telnet: Temporary failure in name resolution Host name lookup failure

I have not done any other changes anywhere.
I am currently using Slackware 10.0
I know I have to do some settings somewhere, (maybe edit some files to tell telnet where to lookup for hosts etc)

But at this point I am completely clueless :confused:

Thanks in anticipation

nixcraft 08-26-2005 02:42 PM

Yup you need to setup linux as dns client see by editing /etc/resolv.conf file

koodoo 08-26-2005 05:25 PM


Thanks Nixcraft for the reply and the link. I'll check it out and see if I can get telnet running.
Thanks :)

koodoo 08-27-2005 09:55 AM

Hi Nixcraft,

I read the link you gave me. It said :


1) Open /etc/resolv.conf file:
vi /etc/resolv.conf

2) Add ISP nameserver as follows:

Note Max. three nameserver can be used/defined at a time.

3) Test it with nslookup or dig:

This is what I know about my network :

I.P. address of the proxy server :
default gateway :
preferred dns server :

So, I believe my /etc/resolve.conf should look like this :

search  <should this be there or not ?>

Is this right ?

I am not at my Linux box right now, so I cannot test it right now.
Thanks in anticipation.

nixcraft 08-28-2005 05:15 AM

Following shoud do the work:


You need to add default gatway using command:


route add default gw dev eth0

Btw proxy has no use to telnet as it will be used by ftp or http or https protocols only.

koodoo 08-28-2005 02:39 PM

Sorry, I couldn't get it to work :(
My /etc/resolv.conf looks like :

root@knapsacker:/home/koodoo# cat /etc/resolv.conf

Then I tried to execute the command "route add default gw dev eth0" and got the following error message :

root@knapsacker:/home/koodoo# route add default gw dev eth0
SIOCADDRT: Network is unreachable

Now this might be because my I.P. is (private i.p.) while that of the default gateway is (I mean they belong to different classes of I.P.'s)

I then tried those two commands and got the following error messages :

root@knapsacker:/home/koodoo# nslookup
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
;; connection timed out; no servers could be reached

root@knapsacker:/home/koodoo# dig

; <<>> DiG 9.2.3 <<>>
;; global options:  printcmd
;; connection timed out; no servers could be reached

Then I went to

That site told me that my D.N.S. servers were :

So then I added these two entries also into /etc/resolv.conf and tried the entire procedure again, but got identical results. :cry:

I would again like to mention the complete scenario here :

I am connected to a proxy server which has i.p.
We have been allotted private i.p.'s and mine is :
Other information is as follows :
default gateway :
preferred dns server :
other dns servers : and

What should I do ? :confused:
Help needed :cry:
Thanks in anticipation.

nixcraft 08-29-2005 09:08 AM

Get correct IP info from your ISP or net admin coz procedure is same and it should work out

koodoo 08-31-2005 03:02 PM

Hi, I'm afraid I can't do that.
My University has got a dedicated lease line from the ISP, and then they have done campus wide networking.

We've been allotted these i.p.'s by the net administrator and we cannot change these.

Isn't there any way to connect to a site via telnet in a scenario like mine?
I think that there ought to be some way (Or maybe I am doing something very stupid)

Somebody, please help me out :confused:

Thanks in anticipation.

koodoo 09-08-2005 05:10 PM


Finally got it to work. I changed my i.p. to the same class as that of the default gateway. (I chose as the i.p.). Then added the default gateway and it worked. :)

But the problem still remains :(
I just changed my i.p. to test whether telnet was working or not. I cannot permanently keep this i.p. Ultimately I will have to use something like and then the same problem would occur again. Isn't there any workaround, so that I can keep as my i.p. also, and still connect to the outside world via telnet ??

Thanks in anticipation.

kingkoti 02-11-2008 05:09 PM

check this it may help you
this link may help u <>

Tinkster 02-11-2008 08:59 PM

Ummm .... not that we have a hard and fast rule for this, but re-animating
a thread that was dead for over 2 years is at least considered weird. Plus
the guy had his problem resolved already?


All times are GMT -5. The time now is 03:19 AM.