LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   tar problems (https://www.linuxquestions.org/questions/linux-newbie-8/tar-problems-281343/)

jecvdv 01-23-2005 04:10 PM

tar problems
 
Hello, I do not know much about Linux, and I should mention I am not actually running linux but rather Cygwin (linux emulator) on a Windows 2000 comp. I beleive you might be able to help though.

I have downloaded a file, 'beta.tar.tar', when I try to extract it with

tar -xf beta.tar.tar

I get the following error

tar: This does not look like a tar archive
tar: Skipping to the next header
tar: Archive contains obsolescent base-64 headers
tar: Exit delayed from previous errors

I did manage to tar this file once before and extract it, although I do not recall what option switches I used to do it. I have tried to 'gzip' and then 'gunzip' the file, as I saw that mentioned as a fix to this issue on a forum, but no luck.

Can anyone shed some light on my problem? Thank you.

michaelk 01-23-2005 04:19 PM

It is probably a compressed tar file i.e. tgz. Have you tried
tar -zxvf beta.tar.tar

jecvdv 01-23-2005 04:20 PM

haha! Yes thankyou!

-xf did not do it, but -zxvf did work. As I stated I am clueless with linux, thank you.


All times are GMT -5. The time now is 08:33 PM.