LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   talk (https://www.linuxquestions.org/questions/linux-newbie-8/talk-100340/)

mairul 10-04-2003 11:04 PM

talk
 
I have changed the /etc/xinet.d/talk file and write disable=no

But cannot establish talk connection between tty and pts/1

error on reading from talk daemon...connection refused...

please help.

rahulsundaram 10-06-2003 12:05 AM

hi

chkconfig --list | grep talk should list talk as on

else

chkconfig talk on would enable it

iptables -L should list firewall rules. make sure you are not blocking it

regards
rahul sundaram

mairul 10-06-2003 04:16 AM

Boss...it is not working....can you help me more....

iptables -L shows a long list...I am newbiew....pls help...

rahulsundaram 10-06-2003 12:38 PM

hi

517/udp is the port used to connect to talk. if its not explicitly disabled i need you to post the iptables rules. if its redhat it will be in /etc/sysconfig/iptables

nmap localhost

will tell you which ports are open. hope that helps

regards
rahul sundaram

mairul 10-08-2003 06:14 AM

My host name is pc2 and IP is 192.168.0.2

when i give nmap pc2 command it shows....

[root@pc2 /]$ nmap pc2

Starting nmap V. 2.54BETA31 ( www.insecure.org/nmap/ )
Warning: You are not root -- using TCP pingscan rather than ICMP
Interesting ports on pc2 (192.168.0.2):
(The 1549 ports scanned but not shown below are in state: closed)
Port State Service
21/tcp open ftp
22/tcp open ssh
23/tcp open telnet
111/tcp open sunrpc
1024/tcp open kdm

rahulsundaram 10-08-2003 02:39 PM

hi
it looks like talk is disabled. run this

chkconfig talk on

chkconfig --list | grep 5:on should list talk as on.

iptables -F would flush the iptables rules

then try it from another system

regards
rahul sundaram

mairul 10-09-2003 08:10 AM

Thanks Mr. Rahul Sundaram...

Actually I edit the /etc/xinetd.d/ntalk file and then write disable=no.....then it is working...

But another problem...how can I accept talk request...

when I am giving talk request it says.....

[rony@pc2 /]$

Message from Talk_Daemon@pc2.com at 18:15 ...
talk: connection requested by root@pc2.
talk: respond with: talk root@pc2

i think I have to press any key at keyboard to accept talk request...

can you help me again pls...

:) :) :newbie:

rahulsundaram 10-09-2003 01:28 PM

hi

the user at the other end has to respond to your request with talk username

read

man talk

or in konqueror

man:/talk or #talk


All times are GMT -5. The time now is 04:02 AM.